Download

Could not find file UE4Game-Info.plist / No Provisions Found

Like many others I’m struggling with de provisioning to launch my project on iOS. I read the UE docs, the Q&A’s and 16 - iOS Set-up and Development - YouTube to setup my project for iPad.

Downloaded the .cer and .mobileprovision files through Apple developer account (Certificates, Identifiers & Profiles). Made sure the Bundle ID matches that of my project.

When I use Iphonepackager to ‘import a mobile provision’ > no check appears, only 'Could not find file … UE4Game-Info.plist. I searched for this file, but didn’t find it anywhere.

When I use ‘Import Provision’ under Edit>Project Settings>iOS in UE4.15.1… I get ‘No Provisions Found. Please Import a Provision’. (Import of the Certificate was succesfull I guess, since it mentions my developer name and status ‘Valid’.)

In UE tried to ‘Launch’ on device All_iOS… but then UE seems to crash.

Need to finish this project so all suggestions are welcome.

Please Epic, is it a bug, can you update the docs or make this flow more intuitive?

Thanks, Patrick

1 Like

Hi.
I experienced the same problem.
I found a solution myself.
I downloaded UE4.5.1
I opened a new project with UE4.5.1
New Project: My documents/Unreal Projects/Test 4.5.1/Build/IOS/Info.plist copy
Real Project: My documents/Unreal Projects/Test 4.15.1/Build/IOS/paste here.
and C:\Program Files (x86)\Epic Games\UE_4.15\Engine\Build\IOS\ paste here.
Info rename after.
This worked on my project.
Good luck.

1 Like

If anyone is still having issues launching your iOS game on your device, you can try the following:

  1. Use the “IPhonePackager.exe” only to generate the “Certificate Signing Request” (It seems that after UE4.5 Epic deprecated its usage)
  • If you really want to use “IPhonePackager.exe”, you have to download a file called “UE4Game-Info.plist” from the 4.6 branch of UE4 in github and place it in your UE4 installation directory under: “UnrealEngine/Engine/Build/IOS/”. If you don’t do so, you will get errors on the IPhonePackager console.
  1. Remove all obsolete provisioning profiles from your project - Remove obsolete mobileprovision profiles
  2. Remove all your certificates from your project (not quite sure how I did that, because it was a while ago)
  3. Reboot your PC and verify that you don’t have any provisioning profiles or certificates in your iOS settings of your UE4 project
  4. Go to your apple developer console and remove all Certificates, Identifiers and Profiles
  5. Follow the official iOS provisioning guide from Epic
  • Important information about the identifiers step:

    My **identifier** in the apple console is using a wildcard and it is: **com.mycompany.***
    The **bundle identifier** in iOS project settings is: **com.mycompany.mygame**
    
  1. My certificate did not work right away. I had to wait for a few hours
  2. I was not able to launch the game on my iOS device, so I had to first package it and upload the .IPA file to my iPhone via “IPhonePackager.exe” Advanced Tools Tab.
1 Like