Could not be compiled. Try rebuilding from source manually. Error MSB3075

As stated in the title it won’t build the project. These are the 2 errors I get. I’ve been looking for answers for about 8 hours now and I can’t figure it out. I’m not a programmer so any help would be greatly appreciated. Thank you

Error System.IO.FileNotFoundException: Could not find file ‘C:\Users\Admin\Documents\Unreal Projects\DreamChante2\DreamChante.uproject’. DreamChante C:\Users\Admin\Documents\Unreal Projects\DreamChante2\Intermediate\ProjectFiles\UnrealBuildTool 1

Error MSB3075 The command ““C:\Program Files\Epic Games\UE_4.19\Engine\Build\BatchFiles\Build.bat” DreamChanteEditor Win64 Development “C:\Users\Admin\Documents\Unreal Projects\DreamChante2\DreamChante.uproject” -WaitMutex -FromMsBuild” exited with code 5. Please verify that you have sufficient rights to run this command. DreamChante C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets 44

“Could not find file ‘C:\Users\Admin\Documents\Unreal Projects\DreamChante2\DreamChante.uproject’”

Have you verified that your project file still exists? It hasn’t been accidentally deleted somehow?

Thank you for replying. I checked and supposedly the file exists but whatever reason it doesn’t seem to be reading it. I have full control from what I can tell with no restrictions to my Admin account. I don’t know how it would’ve gotten deleted I suppose it’s still a possibility but it doesn’t add up with what I just previously stated. All I did was exit the project without saving and I intentionally did that. I’ve done it before and haven’t had any problems. The worst part of this I don’t even know where to look or what to learn in order to start narrowing down what it could possibly be. Do you think it may have deleted a file from not saving somehow?

I’ve done a little more digging and the file ‘C:\Users\Admin\Documents\Unreal Projects\DreamChante2\DreamChante.uproject’. does exist but file DreamChante C:\Users\Admin\Documents\Unreal Projects\DreamChante2\Intermediate\ProjectFiles\UnrealBuildTool 1 doesn’t or at least it can’t find it. Am I toast?

Hmm… Have you tried deleting your Saved and Intermediate folders and regenerating your solution files? If not, could you do that and let me know if you get any new errors?

I found the Saved and Intermediate folders but how do I regenerate solution files and where do I look for them?

I googled what you were referring to and I deleted the specified files and regenerated the sln file went into MSVS and when I tried building it I first got the message

It has asked me this for every different copy I made of the game sometimes it says win32 other times it’s win64. I clicked yes and it started to build them this happened


This is new to this particular copy of the project some of the other project copies did this too, however I was trying things that I had read off the internet otherwise what I had originally posted was consistent with all of them before experimenting.

Okay so for that error what you’ll need to do is go into the solution explorer, right click on your project (not the UE4 project), and click “Set as StartUp Project.” For some reason when you re-generate the project files the wrong default project will be set and you’ll see the error you’re seeing about being unable to find UE4.exe.

I’m assuming you mean this folder


I right clicked and selected the button and it took me to here

What should I change inside of here since there are a fair amount of options assuming I’m in thee right place?

Nope, that’s the solution and the solution properties. Here are illustrations of what to right click on, and then where to click afterwards.



Did this. Now I’ve got this message and only this message from VS


I was using the local windows debugger the project was set to win32 I have x64 so I tried right clicking the project pressed build said it couldn’t build because the project was built in 64. So I went into Solution>ConfigProperties and changed the project to win 64 I was unable to change the UE4 to 64 it only has win32. I built it then got this message

1>------ Rebuild All started: Project: DreamChante2, Configuration: HTML5_DebugGame_Editor x64 ------
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets(48,5): warning MSB8005: The property ‘NMakeReBuildCommandLine’ doesn’t exist. Skipping…
1>Done building project “DreamChante2.vcxproj”.
========== Rebuild All: 1 succeeded, 0 failed, 0 skipped ==========

I also tried the project rebuilding it same result. So then I went to the Solution pressed rebuild then I got this message

1>------ Build started: Project: UE4, Configuration: BuiltWithUnrealBuildTool Win32 ------
2>------ Skipped Build: Project: DreamChante2, Configuration: HTML5_DebugGame_Editor x64 ------
2>Project not selected to build for this solution configuration
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 1 skipped ==========

Did I do what you meant or did I do something wrong?

What configuration (DebugGame Editor, DevelopmentGame Editor, etc.) and platform (Win64, etc.) are you building for? What happens if you go to “Build > Rebuild Solution” and then try to run after that? Do you still get that error message?

Config is HTML5_DebugGame_Editor x64 and build is unchecked below is BuiltWithUnrealBuildTool Win32 build is checked and there is no option to change from Win32

Try making a “Development Editor” build for Win64 (note that UBT is always Win32, that’s fine) and see if you can run your editor from there. Your builds are succeeding (as noted by “Rebuild All: 1 succeeded, 0 failed, 0 skipped”), so it may have something to do with the HTML5 part of your configuration? I have no experience with HTML5 builds, though.

Those errors are suggesting that you’ve got functions declared in your header but not defined in your source files. Specifically the constructor, “BeginPlay,” “Tick,” and “SetupPlayerInputComponent” functions inside of your “AEnemyCharacter” class. Did you maybe delete them in the source file (EnemyCharacter.cpp) and then forget to delete them in the header (EnemyCharacter.h)?

This is the current config

This is the new list of errors

I’m not a programmer but I was following the UE4 bp twinstick shooter tutorial and there is C++ programming in the tutorial. I built it about 2 months ago and didn’t have any problems using the engine on a daily basis. But based on the new errors I’m starting to wonder if that is the cause of this.

I don’t recall deleting either of those things I remember wanting to but never getting around to it. Should I try deleting them inside VS and see what happens?

There is only one other class but but it’s the opposite because enemy character is based off of my character. So I’m assuming I will have to delete my character with the same method?