Coordinates Coordinates Coordinates

Importing Z+F laser Scans
Registration - Exact
Geo referenced - YES
Coordinate System - Local

I expect these scans then to be imported Exactly as they have been registered. I import the targets coordinates CSV (ground control points) file and expect to see those targets in the same scene, however they are miles away.

We check the properties of a single scan. So the software knows where the scan should be however even though you have imported the Exact position, the scans are in a registration pose with meaningless coordinates.


How do I get the scan where I asked them to be?

The whole coordinate system in this software is buried in tiny settings boxes, whereas it should be foremost and easily navigable by the layman. I am a land surveyor and every time I use this software, which isn’t often, I lose hours and hours trying to gig my data into the correct position.

1 Like

Hi D2RS,
this is a really strange behaviour and it shouldn’t happen like that.
What do you have set as project and output coordinate system in your Application settings?
What are your alignment settings?
I tested this and for me are the coordinates the same before and after alignment.

had similar issue, this post might help

(Geo-refrenced laser scans are moved? - #3 by Mr_Joshua_R)

Gents, thanks.

I started over with a hold shift reset. This worked for reasons unknown. Down the line, I ran into more coordinate issues. Having registered my image project to the scanner targets, I tried to merge components. Many times in fact. So even though both components are registered to the exact same targets (ground control) they wouldn’t have it. I had to ping the targets in the scan project to drag the image project to it. Or did I find the setting “merge georeferenced projects” Y/N setting was off. You know what I have forgotten. I have two more similar small projects to do this week, so I intend to document my workflow. We could do to have a dedicated COORDINATES tab at the top to easily see all the coordinate settings of each input / component instead of digging around in these miniscule boxes.

The reset should help as it changed the settings Use camera priors for georeferencing from No to Yes (as it is the pre-defined setting).
For two different datasets the control points need to be placed on both components to merge them. If you have georeferenced components then Merge georeference components will help. There are some tutorials on our YouTube channel how to merge laser scans and images.
I added your idea to the feature requests database. Thank you for pointing it out.

Here we go again.

So we have figured that even though I import scans as exact, I have to previously have set use camera priors (even though they are laser scans so we are not really looking at this setting) to YES. Logically, I’d expect your import sequence to override this setting or give me the option during. Otherwise, the scans don’t import as exact. Do you see where I am coming from?

Above I had my laser scans in the correct location, checked by importing the site ground control points. I locked pose for continue. I then imported my image component, which had been aligned to the targets. When I imported the image component the targets appeared in the scan scene so we know both components are registered to the same coordinate system as expected.

After alignment, the scans are miles from the targets on their side, while my image component is over there with the targets where it should be. So the scans are not locked, they have moved.

In the videos, I don’t see anyone marking the targets in the scans, and why would you need to if both components are registered to the same coordinate system. The images should drop over the scans like a snooker referee’s glove.

So now I have to do this time sapping trial an error, watch the tutorials again until I mistakenly stumble upon the right settings and sequence.

Lets’ think about two drawings in Autocad in the same coordinate system, check the units XREF and boom, one drawing is aligned to the other perfectly.

This makes no sense.

It seems like there is something wrong in the process or used settings. It should work as you described it.

Regarding Use camera priors setting, RealityCapture works with laser scans as images. Therefore the name is set like that.
Lock pose for continue settings lock only the relative positions between cameras, not the absolute position.
If you have two georeferenced components after image’s import, do you set Yes for Merge georeferenced components in the Advanced alignment settings?
If this won’t work, would it be possible to share your data with us for some internal tests? If so, can you contact our support directly at

I am back on this today. I’ll get in touch directly shortly.

This seems like the only way I bring the images to the scans. After importing the image component, the targets from that component show up. If I go around marking these in the scans, the images will align to the scans. It seems a bit rough to do so. In ZF laser control, I have already registered these scans to these targets with automatic target recognition. We could really use this in Capturing Reality to remove the human judgement.

What I don’t know for certain is if my scan data has moved globally or stayed put. I am sure you’re aware that the scans are the most reliable positionally and dimensionally.

Tip from Autodesk Recap, where ever I point the mouse in the scan data, I can read the coordinates. This provides certainty.

The suggested coordinates tab would group the inputs separately and list their corresponding coordinate settings. It gets further confusing when you have two components with different settings.

You can check the scan movement by comparing the prior and registration pose after alignment.
I added your tip as a feature request.

In the scene are the scans, they are in the correct position as I have also imported my ground control targets, and they are in the scene as I would expect.

When I select a scan, the coordinates are correct in prior pose, absolute coordinates.

I did have an image here but apparently I am a new user even though I have been using the software for years.

So all good I will delete the targets and export this registration component.

Here is my sparse point cloud generated from the image project with the very same ground control points in the scene. I have marked the targets in this images.

I did have an image here but apparently I am a new user even though I have been using the software for years.

Now I will import the scan component and merge (align)

The two components didn’t merge. The scan coordinates have been shifted without my express permission to some irrelevant coordinates, even though the software knows exactly where they should be.

I did have an image here but apparently I am a new user even though I have been using the software for years.

You don’t need to export the laser scan component (by the way, what are your Project and Output coordinate system settings for this?). Just import the images here and use your GCPs to merge the datasets.
Are you using Merge components or Align Images option?
Are the GCPs placed on both datasets? Have you tried the Merge georeferenced components option?

It may be related to ZF Control. Perhaps the coordinate system doesn`t exist in the scan header. Give it a try.

My ZF Coordinates are updated to the scan files, I verify their position by importing the same targets used in ZF as GP’s and they appear correctly in the scene.

I have tried merge components and I have tried align images. My project coordinates are local, truncated OSGB.

Today I have both the image model with marked targets aligned to itself and the scan model with marked targets (though I shouldn’t need to as they are already registered) both scenes have the same targets in their associated scene and both are miles apart.

The scan data is in the correct coordinates as imported. Verified by importing the GP’s, I have even re-marked the scan targets, which I have already done in ZF laser control.

The images have the same targets with the same coordinates marked, they have aligned but are miles from the position of the coordinates in the targets.

Use camera priors no
Merge georeferenced components, yes.

These two images are in the same project and will not align!

This is a bit silly too, when importing a component with the same GP’s you double up.

This is the problem in that the software is dumping the data in an arbitrary, meaningless coordinate system that nobody asked for. There are only 2 sets of coordinates, the targets in a local grid as per the scan data and the camera rough exif coordinates that we are not using. Why then is the software dragging the data around 0,0 without permission.

Firstly, the main screen needs a mouse pointing coordinate value box which updates wherever the mouse is pointed. This is so we can immediately verify where we are.

Secondly, you need a coordinate Q&A on import. “Are these inputs PPK processed with accurate EXif” “Do you want to keep these coordinates?” etc etc.

Thirdly we need are own tab for all the coordinate settings in the job in one place. All Photos - This Setting, All Scans - This setting, All Targets are…

The path to coordinate righteousness is before us, only it will take some programming, which I cannot do.

Hi @D2RS,
I am sorry to hear that.
But there is something strange in your workflow.

Just quick notes:

  • for laser scans you don’t need to use Lock pose for continue option
  • as you are using No under Use camera priors, the GCPs need to be placed on at least two LSPs, not just one
  • first of your request was already added to our database
  • regarding your second request, all of these can be set during or after import of the data
  • regarding to your third request, this is in 1Ds view
  • if you are getting copies of your GCPs you can drag and drop the point to the one where it belongs:

I’ll try to describe all steps to get the data aligned.
First of all, it would be good to use Make it like a clean install (application reset) before start.

Then, go to WORKFLOW/Application/Settings/Coordinate systems and set local for Project and Output coordinate system (as you are working in local system).

Import laser scans using these settings:
Feature source depends on your data.

Import images.
Select just images in 1Ds view and set the Prior pose/Absolute pose to Unknown

Import GCPs. Be aware of the right settings (mainly for format and coordinate system).

Align data. This will probably create two components. The laser scan component should be georeferenced and image component shouldn’t. In your case both are georeferenced:

Place the GCPs over the image’s components (each point on minimally three images, evenly spread around the dataset, but around 10 images will be better).

In the alignment settings set Merge georeferenced component option and align again. Now the data should be aligned.
If not, place the GCPs also on LSPs (at least two, in your case they are on only one) and align again.

Following these steps you should get aligned laser scans and images.

Please just add a search bar on the settings panel. This is insane. Finding the correct settings for this app is such a pain. And the text is so tiny. Also is there a way to disable the settings stacking? When I click on a setting id prefer that the old setting would go away. Or maybe color code the panel a bit more. By the way I’m here because my lidar scan also keeps moving when it should not.

Hi @tgvfx1182,
I added your notes to our feature request database.
Regarding the small text, you can change these settings to show it bigger:

And about LiDAR, were you followed the previous advices?
What are your steps and used settings?

1 Like

Thanks for the tip.

Joy of Joys RE Text size to 125%


I have just managed to merge laser scans and image components in under half an hour! Progress.

For laser scan component:

Application Settings
Coordinate Systems
Project Coordinate System - Local
Output Coordinate System - Local

Alignment Settings
Use Camera priors for georeferencing - YES

Laser Scan Import
Registration - Exact - use existing registration (refers to scan to scan relations)
Georeferenced - Yes
Coordinate System - Local

Check position by importing the scan target CSV file. The targets should appear in the scene. Export component.

Open the image project and import the scan component.
Merge Components
Alignment Settings
Merge Georeferenced Components - This was set to NO I am guessing it should be YES and would have worked then if I had just selected standard align.

I think we are there. Thanks for your inputs.

Next problem, how do I apply a false origin so my coordanates are in OSGB ready for Nira.