Cooking on linux

Hi, I am trying to build the starter 3d person c++ project on linux.
Compiling the engine (4.5 branch) all worked out, but when I try to run the UAT script as described at A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums as follows from the root of UnrealEngine

Engine/Build/BatchFiles/  BuildCookRun -nocompile -nop4 -project="/root/projectdeckchair/ProjectDeckChair.uproject" -cook -compressed -allmaps -stage -archive -a    rchivedirectory="/root/" -package -LinuxNoEditor -clientconfig=Development -ue4exe=UE4Editor -clean -pak -targetplatform=Linux -utf8output

I get the following error, it looks like it is trying to find my game in the engine binaries folder…

[2014.11.08-16.27.47:963][  0]LogModuleManager:Warning: ModuleManager: Unable to load module 'ProjectDeckChair' because the file '/root/UnrealEngine/Engine/Binaries/Linux/' was not found.   
[2014.11.08-16.27.47:968][  0]The game module 'ProjectDeckChair' could not be found. Please ensure that this module exists and that it is compiled.

Does anyone know what exactly is going wrong?

Thanks, for the reply, I’ll try putting the project in the UE folder first thing tomorrow! as for the root thing, I know it’s not right, but I was being lazy.

Before going anywhere further, please try putting your project folder inside engine’s top level folder. We’ve noticed that building c++ projects works when that’s done.

Also, it is possible that something got broken with cooking meanwhile. When I wrote the Wiki page, it was in my 4.4-linux branch and I haven’t had a chance to revisit cooking in 4.5+. If I find a few moments I’ll give it a try this weekend again on a newer branch.

Lastly, there’s no reason to give UE4 elevated privileges in Linux, nor in general you should never run as a root user all the time.

Putting the project in the engine’s root folder did nothing, still have the same error.

Did you generate project files again, though (sorry, I should’ve mentioned that earlier)?

If you are building a c++ project it needs to compile your custom code and the easiest way it does that is by putting the project into the engine root folder then letting the engine find your code and add it to the makefile.

When I generate the project files again with my project files in the main engine folder I get the following error UnrealBuildTool Exception: ERROR: Not expecting project Engine/Intermediate/ProjectFiles/ to already have a target rules of with configuration name Game (ProjectDeckChairTarget) while trying to add: UE4GameTarget

The process in epic/master branch would be that you put your project (myProjectFolder) into the UE4 top folder, beside Engine/, Templates/ and Samples/ folders.

Then run ./ and it should add your project to the Makefile.

After that you will have target(s) for your project (verify by just typing: "make " with a space after it, press key then yes when prompted to display all possibilities. You should see your project’s targets listed.

From there you: make myprojecttarget

If it doesn’t find your project you might need to edit the file UE4Games.uprojectdirs and add your project to the bottom of the list, like so: myProjectFolder/ or whatever is the path where the .uproject file is located.