Cooking fails - illegal character

Hello everyone,

When I try cooking my game it fails. Looking through the Log I’m pretty sure it has to do with this issue:

DoesPackageExist: DoesPackageExist FAILED: '/Game/Own/Textures/Standart Boden Textur/Standart_Festung_Boden_Textur_COLOR' is not a standard unreal filename or a long path name. Reason: Name may not contain the following characters:

As you can see I once made the mistake of importing a folder with spaces in its name and, though the folder doesn’t exist anymore and the textures contained in it aren’t used by any object, it seems to still be referenced somewhere in my project.

I have read about the Reference fixing but the error still appeared afterwards.

Do you know if there is a way to maybe delete that reference? Any help appreciated.


Thinks I tried:

Deleting the Folder from the Project manually

  • didn’t work, the folder doesn’t exist

Fix Redirections

-didn’t work, I didn’t even notice anything changing in the project at all

Hello Der. No pun intented.

Have you tried looking in your “Project Folder”? Mine is located in “My Documents” —> “Unreal Projects”. Then open the folder with the project name where you have the problem, go to the “Content” folder or sub folder, and delete the folder that is being referenced.

If that doesn’t work, please, reply to me and I will see if I can find another way to fix it.

Yeah I tried it before. The thing is that the folder doesnt exist :confused:

Hm…okay, I will look up some stuff and get back if I find anything. :slight_smile:

In the meanwhile, if you really need to get it to work in a hurry; well…this is not really solving the problem rather it’s more of a “work-around”. Make a new project and migrate it into that new project’s Content folder.

And remember to make a back up of your current project, just in case anything bad happens.

I am trying to recreate what you did. Could you tell me what you did, exactly? Or well, the most important part? How did you import the folder into the project?

When I tried to make a folder with a space, it just said that it wasn’t allowed. Then I went to the Project Folder and created folder with a space. But when I Launched it, it just created the folder with an underscore, instead. I am using UE4.9.2

I am using UE4.9.2 as well.
I created a folder (“Textures”) and put the folder with the spaces in there (“Standart Boden Textur”). I then dragged the Textures folder into the content browser (to import it). And the name of everything inside the Textures folder didnt get the spaces replaced by underscores.

Hmm…well, I am sorry it’s taking so long. :slight_smile: I am thinking as hard as I can. :smiley:

Maybe you could try to create the folder with the same name and put it in the folder and see how it reacts to that?

Thank you :smiley: I think it solved it. I’m not sure yet though cause UE now tells me: “Missing UE4Game Binary” (BTW; I have packaged and Cooked the Game before and I never had those issues)

I am happy to hear that! :smiley: Hurray!
I am not sure about the “Missing Binary” stuff, though. :frowning: I hope you can get it to work!
Good luck! :smiley:

I ignored it and it went away (<-- that actually is what happened) :smiley:

Okay, I managed to find the solution with the help of Lucas.
First off: That bug was created because UnrealEngine doesn’t replace illegal characters from files inside folder when you import them.

The way to fix your project again is to get a folder with the exact same name into the same location and delete it. UE will then not try to find it anymore.

For me that ment to put a folder called “Standart Boden Textur” into “/Game/Own/Textures/” and delete it again.

I hope that helped. And thanks to Lucas once again.

I am happy that was able to help you and that we were able to figure it out! Take care and have a nice evening! I hope you won’t encounter this problem again! :smiley:
See you around! :slight_smile: