Conveyor volume takes VR hands with it

Hi All,

Trying to create conveyors in a warehouse, I have followed a tutorial found on the net for creating the volume that transforms the object which works great. But If i put my hand into the volume it goes with the object and shifts the hand to a new position. Is there a way to exclude the hands from the array ? This was the tute i followed.

You could cast to your hand blueprint in the loop of overlapping actors and ignore if the cast succeeds. That way it wont add the offset to your hand.

The better method would be to have the belt ignore overlaps of the type of collision your hand mesh is. This can be done in the collision presets when clicking on your overlap box/mesh.

GetOverlappingActors has a Class Filter option which you can use to limit the returned list of overlapping actors to those derived from a specific class (Blueprint). If you make all the objects on your conveyor belt derive from the same base BP, then you can use this class as filter, which will exclude all the rest (including the VR hands) from being transported by the conveyor belt.

I somply used Get Actors with Tag, so that only those actors are affected by the Overlapping event.