Download

Controller beam lagging - why ?

So, apparently simply parenting beam to Gear VR controller in the components hierarchy window doesn’t work. I had to do this to make beam show up as if it’s coming out off the controller:

6471a18d59c1b023d7df0558f8efdd0183768c88.png

It works, but beam static mesh component lags behind when I move controller around:

That kind of lag doesn’t seem to be present in the Oculus Home.

Any idea what’s going on? Thanks beforehand

Looks like you have Late update on. To my understanding, when you set a property like transform, it will not get the late update transform. Only if you have the beam attached to the MotionController it will excact. Alternatively turn off Late update if that doesn’t bother you. Personally i tried both with on and off, and can’t tell the difference really. Perhaps someone else can enlighten me, why it is super bad practice to turn it off though, because it seems to be the common oppinion.

Also note, if you attach your beam to your MotionController, but set properties on tick, it will again break late update for it.

MordenTral dug into the source and it seems that I need to manually attach component on BeginPlay: GearVRController > Get Motion Controller > attach beam to that. Will test it after work.

Ah i see… Lemme know what you find out… it might also affect me and others, allthough im on Vive.

Attaching manually on BeginPlay worked.

Anybody fancy sharing a small project of how you do it…

I have tried attaching to the Gear Controller…but its being a pain (does it need any update once attached to the Controller) ? (what the settings on the Attach to Component ? - Snap Target apart from scale ) ?

I just hate the fact I have to compile for the phone each time (round trip 4 mins) …ah to be able to test on PC !!!

OK UPDATE…managed to get a pointer sort of working… (was attaching the parent and pointer wrong way around…haha)

Has anyone got the the “widget interaction” thing working ? - I want to press buttons

It’s literally just this:
ae941816e31115be9185e3976224a55195d8d3b0.png

https://s24.postimg.org/wj42m90ir/gearvr_controller_setup2.png

Cool…that’s what I am doing now… Do you have any clue about Widget Interaction Component… ?

**
Ok got it to work using the same attachment process**

it seems to be that extra level of (Motion Controller) that’s stuffing up the simplification…

Haven’t messed with that one yet. What’s the issue ?

Strange… any idea why that would make a difference? Bug maybe? If so, you should report it.

Its not a bug, the tracked motion controller component is actually attached to a scene component which is named the GearVRMotionControllerComponent. So you can’t attach things directly to it since the root is not the tracked component.