Download

Continous Memory Leak problems.

So I tried multiple times to give this engine more chances but with the Memory Leaks its impossible.

Has Epic ever done anything about this? First things first in the past I have never had Memory Leaks as bad
as the current versions and my system has 8GB yeah I know to most of you “ITS LOW” to that I say get out of here!

I have had used this engine for a good long time and my levels are built efficient I take good use of my hardware and
when it comes to the engine I very well remember having the Engine, Microsoft Edge, GIMP and a bunch of File Explorer windows
opened with a level that the engine is struggling to draw with the same amount of RAM now even dough in the past this was not a issue and now it is.

I cant do much with this engine as far as to what I see Epic failed to do some proper fat trimming with the engine cause
it just loves to F*** up my memory, this is crazy I at times go out of my way to make a empty “EMPTY” BLACKER THAN BLACK, isolated, nothing in it
and the RAM usage still goes up and when I tried importing a character with that level open it killed itself with its favorite message that the RAM is Low.

Not just that I dragged the Unreal Editor to the top of the Right side of the screen so it can snap in place when I was about to add the textures to one of the
characters which worked the next time I tried to import it and it got stuck for about a good few seconds and lor and behold my VRAM got screwed again also
the screen went black this is already the FOURTH time the Engine has massacred my display to a black unresponsive screen.

Come on quit defending it “I know you people are out there” there is a problem here is a video showing whats going on:

https://youtu.be/bpaFhe2a_y4

The video is in Russian I can read Russian but you don’t have to read it to understand the problem its Pre-school, a da_n_m …kid could understand whats happening…

Try to upgrade to latest engine 4.16.2. The youtube video is from 2015 and to support (and also to complain) properly, you have to use at least 4.15 or newer. The more recent version has fixed bugs in older version, so the memory leak bug may have been fixed.

Everything is updated and running the latest that video is just to show the problem in action, I was just dealing with blue prints and I got a pop up that I’m out of Video RAM… WITH Blueprints really?
I love to see some one defend that.

Look this issue has been there since 4.15 if I’m not mistaken I’m using the latest one and this isn’t the most stable infact il go off to say that 4.16.2 is the worst UE4 I have ever used there is no real
reason for this to happen my game is not memory intensive and I’m fed up with people defending Epic with this 2GB GDDR5 RAM and its already giving the GPU a hard time with the black screens and that
card is new.

Come on its leaking Memory and whats worse was that I had to optimize my game cause I originally thought it was my game and turns out once I found out what the problem was I killed the games design
for nothing only for a screw up on Epics side.

The game itself has also killed itself due to low Memory and I know my levels well they hardly exceed 3GB some are much lower than that and when it comes to CPU it does a good job leaving that thing alone
as much as possible.

No its not fixed the issue is still there.

Are there any errors with Accessed None in your log?

Ping @ErnestoEFL

If there’s a significant memory leak, I sure haven’t seen it, and nobody else is reporting it.

AnswerHub questions about Memory Leaks Search - UE4 AnswerHub

None of which appear to be relevant.

Its broken the only thing I could have had thought of was changing Visual Studio to 2017 and it did only two things Jack and S*%…

I don’t know whats going on but its very clear what the issue is it just keeps leaking memory also I was using the Blend 1D thing for my characters
animations and I was trying to adjust the size of that dark grey bar and it locked up for about 4 seconds and my screen went black… ANOTHER
UNRESPONSIVE BLACK SCREEN this is the FIFTH one this da nm engine has caused as far as to what I can see this thing is slowly killing my GPU.

"If there’s a significant memory leak, I sure haven’t seen it, and nobody else is reporting it. " I’m pretty sure I had but of course no actual word from the
da.mn mods.

Also out of being stubborn I left the engine running for a while and saw that the RAM was at around little to
2,000MB with some change but it don’t matter it still kills itself.

Also with the whole “You need more RAM thing” its pointless it will just continue to increase the usage which is why I also put the video to show that a high RAM
PC also has this problem.

I can almost guarantee that this is user error, it’s really rare for the engine to have a leak that’s so prevalent that it breaks day-to-day usage. 2GB isn’t much memory for the editor either really, I regularly get up to 3-4 in editor (but it really depends what you’re doing), and when working with large assets I’ve exceeded that before and been running into my page file… My machine(s) is/are 16GB.

There are a number of ways you can track down project-related memory issues. The first and fastest one, is to enable the object counter in the editor. Go to Edit->Editor Preferences->General->Miscellaneous->Show Frame Rate and Memory. You’ll get this counter at the top-right of the editor viewport:

6dc3be4ec9e633e45ac2ae49adf0bb990bad8ee9.png

If that number on the right is increasing over time without you really doing anything, then you’re creating objects somewhere. If you start playing your game and it’s going up faster than you can count, then you’re spawning way too many objects somewhere. That’s the first test.

Next step is to find out whats causing the editor to behave poorly. Go to Window->Developer Tools->Session Frontend. Then double-click the session on the left, and open the ‘Profiler’ Tab. Hit the ‘Toggle Live Data Preview’ button, and you’ll start to see stats flooding it. From this, you can work out what specifically is causing your performance issue.

6678a9c778707d8d8f603312f08243156f90d9ac.png


The Memory and Framerate thing has been on the whole time

Its impossible my computer runs out of RAM before its even close to finished.

Also the engine crashed which I’m happy because it didn’t kill my VRAM and leave me with a black screen.

Creating objects makes no sense because it can be anything from the Blueprints themselves which is a pathetic reason for the memory
to leak like I said the video I posted shows the problem in action and this guy has more than 8GB of RAM cause I love how people blame
me for only having 8GB it being to low, but come on Blueprints… there is no excuse for that to happen other than garbage testers at Epic
who do a terrible job at checking for errors.

It’s not impossible at alll, you should check the task manager to see how much RAM you actually have available before even starting UE4. There’s no way you have 8GB available if you’ve got 8GB in your machine. I tested the 2 year old method in the video of opening a blueprint and closing it, the RAM usage didn’t increase.

Also your crashes might not be caused by RAM at all, 2GB VRAM is pretty low too.

On topic though I have found two memory leaks using UE4, one was Unreal Engine Issues and Bug Tracker (UE-43455) which is fixed for 4.17. I guess it’s technically not a leak, more like memory not getting garbage collected but anyway. The other was a material instance which increased VRAM usage by a lot when dragging sliders, I think that was caused by upgrading engine versions, but after remaking the material instance I haven’t reproduced it since.

Alright fine lets see I’m using Windows 10 which is already a bad step because unlike 8.1 it uses much more RAM for example when I had 8.1 it had about 16% of Memory in use which was alright by me but with 10 “CU” it is using 29% with Microsoft Edge opened but the RAM decrease on this is far beyond my reach Windows 10 loves to just use RAM randomly especially on filth I know I don’t ever use like Cortana.

It compresses the In use memory from 2.2GB (45.8MB) I don’t know whats going on there too much.

Background wise its mostly Typical Windows stuff and some NVIDIA BG processes but that’s not much.

But despite this Windows 10 has always been used to make the game I am using and never experienced the Low RAM pop up as much it all started with 4.15 and 4.16 I clearly remember using several tasks with the UE4 opened with 8GB of RAM it barely made a dent now it does not want anything opend… Even itself a message will pop up to Close Unreal Engine 4 because its using too much RAM.

I have been using Windows 10 since its release and with it the Unreal Engine 4 I have never had this issue in the past and yes the level designs are the same except the biggest one I shrunk slightly to save memory but it still gets killed and if the issue is Windows 10 “Doubt it, because I been using Windows 10 for years and the RAM usage hasn’t changed” I cant do anything about it the computer I own does not go any higher than 8GB of RAM that’s the max it will go.

If its too low for the VRAM to be 2GB and 8GB for Memory than fine its low I personally don’t have a problem with it I work with Optimization and I make sure my games run as efficient as possible and use little power as possible the game does not use much resources to play it, which is also part of the reason why originally I was going to use the CryEngine to create
the game because its super lightweight and requires little RAM but I skipped it because at that time you had to pay monthly for it on Steam and at that time Unreal made the UE4 free so I gave that a shot.

I don’t know what to do the games been on development for 3 years now going to 4 in like 2 months its not a simple decision to just shut it down, but I can say for sure this issue wasn’t around in the past like at Early May or June of this year is when this started to happen.

BTW, that video you linked is in Unreal 4.10, and that user has their project open. I bet this is more of the same…

You’re not listening - creating objects costs memory. It’s an entirely valid reason to be running out of memory if your game is creating loads of them in quick succession. Especially if you create those objects and don’t destroy them properly. Is the object count skyrocketing or not? Have you run the profiler at all? Whether you’re using Blueprints or C++ doesn’t matter, the editor takes a lot of memory to run - every object you open and all things referenced by it have to be loaded.

Unless you can provide a project to Epic that reproduces this memory leak, then it won’t get looked at. Memory leaks are almost always project-specific and they can be incredibly hard to track down and find.

This thread is nothing more than complaining - do some of your own diagnostic checks and provide a reproducible case that we can look at on our own machines (think about it - how are we going to find a leak that only seems to happen on your machine?), then maybe we’ll get somewhere.

Everything in that game gets created and I mean everything the second the game is playing there is no object pop in the only thing close to that is the foliage cause it costs way too much CPU that has
objects have LOD but it only subtracts geometry detail not the actual object itself and that’s the way the game has been for years because I know how to shove all that information in the game efficiently
and its been like that for several years nothing has changed the only thing that does change is the Engine with its updates.

There is no need to destroy the objects its always been the way they are and never had problems I built them to be efficient and again its been like that for years.

There is no other objects that get created whats on the level gets loaded the second the game gets run all at once unless its the foliage with its LOD, I have never had this issue were my assets gave me problems
loading them to memory till recently.

Also don’t you think if this was infact the case despite the game being made with the exact same methods I would had given up a long time ago? There is a reason why I still used it because it didn’t happen in the
past and the complexity of those levels are the same as they were over a year ago and I didn’t get RAM issues back then even when I shoved in destruction.

The profiler thing I said it RAN out of Memory before it even had the chance to finish.

I get tired of repeating myself I swear people are… its a video showing whats basically going on with me and the engine that’s it the memory goes up… man I swear…

I’m pretty sure I had but of course no actual word from the
da.mn mods.

dammn, i have 12 gb ram and thats just about enough for me to use unreal. 8 gb ram is always gonna run into issues

Actually there was a flaw with my Windows 10 I accidentally disabled SuperFetch and with that disabled everything not just Unreal Engine 4 had low RAM problems.

So yeah it wasn’t Unreal it was my own stupid decision to disable SuperFetch, my bad on that.

My project started at using 1.5gb ram on the memory counter built into unreal. Over time of mapping and game development in general. Now the editor uses like 7gb of ram buy I have large world Comp maps and large assets. The game runs fine when packaged on an system with 4gb ram. Just my editor now uses more ram I’m assuming from all the assets in the world and such.

I don’t feel it’s a men leak it is just how much stuff I have in the world’s

I just had to load, modify and save about 200 skeletal meshes. I did it in batches of 10, then saved and closed. At the end of the edit process my 64 Gb Ram were full. Clearly UE leaks memory big time somewhere and you have to close it and restart from time to time