Context window flickers when right clicking!

Hi,

Me too i have this problem on ue 4x and 5 ea2, the problem seem occur only on 4k screens, in my case the setup it is not mixed my two screens are 4k, so it can happens on both of my screens.
The problem happens very frequently and there is no way to stop it when he as happens, only restart Unreal fix it until he happens again.
Also when the problem are present it extend to any context menu and menu on the top bar and so on.

Some time sliding the main Unreal window from the screen where the probleme to the other screen make the problem desapear on this screen only, wich is at least better than nothing and allow to finish the node link or save the project correctly etc…
But the problem remain on the first screen where it was occur, and can happens also on the second screen later on after having slide Unreal etc…
So, restart Unreal is almost alway obligate.

When it happens you can usually navigate via keyboard.
Not that it’s not annoying, or something that the epic team shouldn’t fix…

idk if someone has already answered this fix
but the way i fixed it is by changing the max frame rate of unreal to be greater then my monitors refresh rate and that has fixed the problem for me.

Hi,

As MostHost_LA mention, it seam the problem don’t appear when build from source at least with the 5.0 i have build.

I’m still experiencing this after rebuilding from source, toggling all these settings, and swapping my monitor cables. This only occurs on my primary monitor and not my secondary, but is extremely frustrating since that one is set up vertically.
** edit: After some more debugging, turning off g-sync globally fixed the issue for me. Unfortunately setting it to only fullscreen apps and specifically designating it be turned off for UE4 didn’t, but hey at least something worked.

I had this happen on any frequency and on gsync less monitors. Only thing that helped was building from source.
Maybe the version you built has somehow introduced the issue of the release into the code base…

Just learned about this fix from NVIDIA, hope it helps!

https://nvidia.custhelp.com/app/answers/detail/a_id/5157/~/after-updating-to-nvidia-game-ready-driver-461.09-or-newer%2C-some-desktop-apps

[EDIT] Solved the problem for me, never happened again since I applied the fix.

1 Like

I posted about this Elsewhere in a separate thread, didnt find this one at the time, but yeah, same here.

In my case, this happened with a SOURCE BUILD of UE5EA as well.

I found it hilarious that you cant take a screenshot of the issue because in the SS it looks fine!
The supposed fix from Nvidia “may” work, I’ve only just now installed it, will see.
I use multiple monitors as well.
The “overlay” issue Nvidia mentions makes sense, because any Screenshot apparently is taken behind the overlay and wouldn’t be affected.

I used the same link given by zaha:
https://nvidia.custhelp.com/app/answers/detail/a_id/5157/~/after-updating-to-nvidia-game-ready-driver-461.09-or-newer%2C-some-desktop-apps

EDIT: Haven’t had the issue for 3 days now so… Hopefully this fixed it.