Context window flickers when right clicking!

Hello all,

I’m having an issue with the context menu and dropdown menus disappearing. The context menu appears for a quick second, but then goes invisible and the dropdown menus flicker or just disappear. I tried to record it, however, it looks just fine in the video. The only fix that works is to restart the engine, however, this happens quite frequently, so I would like a more permanent solution. I don’t know what triggers it, it’s quite random when it happens, so I don’t know how to help produce the bug.

Any help or suggestion is welcome.

Thank you!

Dual Monitor
GPU: 3080
CPU: 10900K

The fix below, did not work.

This also breaks Chrome, making the whole window black. If I close Chrome down, while UE is having this flicker issue, then reopen Chrome, Chrome continues to be black / flickers black, but if I close UE, regardless if chrome is open or closed it stops being black and returns to normal.

So it seems like this is only happening on my 4k monitor, the 1080p one dopes not have this issue. Any suggestions on what I could do to try fixing this issue on the 4k monitor would be appreciated.

So I changed the windows scaling from 150% to 100% and that fixes the issue, I can also go back to 150% and the issue would be solved as well. I guess this will have to do for now, would like a more permeant solution if anyone can provide one.

Changing UE4Editor.exe “override high DPI behavior” to application, seems to have fixed it.


Having the same issue. So far can’t seem to solve using the steps above. Monitor setup is similar, one 4k, one 1080p on a 2080 Super, with i7 7820X CPU.

Unfortunately, I’m not sure what causes it, the fix I found could just be a temporary one for me as well.

I was thinking, In the Editor Preferences, maybe turning off Enable high DPI support might work, but I’ll have to test that if the issue comes back. I wonder if any of the Dev’s for fortnight or the engine in general use 4k monitors and if they get this kind of issue also…

I tried all the HDPI settings, but after a while it just appears. The funny thing is that I was doing a screen recording to show the issue, and the “corruption” is not seen in the video, which make this even more strange. But thanks for the tips. My colegue with 2x4k monitors doesn’t seem to experience the issue, but is using and older GTX card, and not an RTX.

Do you have Enable Window Animations on?

1 Like

Nope, no animations enabled. Also this wasn’t happening on 4.26, it seems related to 4.26.1. I keep restarting the editor after around 30m of working on materials or blueprints, since the context menus just stop appearing, but, if I do a screen capture they appear in the video :D, nice feature. Going to force dx12 on the editor an see if it helps.

I was getting it in 4.25 and 4.26, and now in 4.26.1, however, it did go away, then it returned for some reason, now it’s gone again, hopefully got a long while. Maybe it something with windows… Or its an RTX thing… Sigh

I’m thinking something more on windows side. Since 4.26.1 came out when I got a windows update also :|. I would be on Linux, but the last time I did, with needed lots of work inside the editor (blueprints and materials for a windows game :smiley: ) it didn’t went well nor did it play nice with the rest of the team, since I had to use a local compiled version and our team isn’t that big to justify custom builds.

Oh, and I did set the -dx12 flag on editor, and so far it seems ok, but I think the -dx12 flag is more psychologic then any thing :smiley: (I don’t think it forces DirectX 12).

Ya, it’s back for me, so any of the fixes in my op did nothing. I’ll add the flag to the project and engine, and see if it happens again, thanks for the suggestion.

Adding dx12 did nothing for me.

Yup, I don’t think it forces dx12 on 4.26 builds. But I did spent the last 2h messing with materials and blueprints and didn’t had the issue. So I can’t figure what “activates” the issue.

I’m having the same issue. Started last week. Any news on this?
Maybe a windows update caused it?

I’ve found no fix to this, it’s still acting up on my end. I’m hopeful when v5 of the engine drops this issue wont be there.

Same here. Tried updating to the latest nvidia drivers (game & studio) no luck.

Keeps happening. I can get away more or less if I use the Editors on the second full hd monitor, it seems to last longer without issues. But I can’t figure out why or what causes it, since it can start happening on blueprints, animation editors, material editor, and then it just becomes unusable at all, with no context or top menus. And the funny thing.
Try to take a screenshot or use OBS to record the issue, and it will not appear on the video/screenshot.

I reinstalled windows today and the issue is gone. I’m on the newest nvidia drivers, but there are some windows updates available. I’m not going to install those for now. I’m pretty sure the issue came with an update, since everything was working perfect before.

From what I’ve read on older posts from previous versions (4.12 if I remember correctly) it’s something related to some windows updates and/or nVidia driver versions. I tried switching drivers but nothing worked. I have it on 4.25 (don’t have .26 yet at all).

Did anyone find a reliable fix for this? I have to restart my editor every 30 mins-1 hour because none of the menus work. 4.25.2

There’s a couple of things that cause my context menus to both go black and also to flicker. FWIW I have an RTX 3080 on updated drivers, using UE 4.26.2.

First, if I have anything fullscreen on my second monitor (videos playing through Firefox, or watching something in VLC, for example) while I work in Unreal on my main monitor, after about 15-20 minutes, the context menus will simply stop drawing anything except black boxes when you open them. I have to restart the editor to temporarily fix this. So obviously the stupid long-term fix is to simply not watch anything in fullscreen on my second monitor. Not great.

Second, the cause of the incessant flickering for me where context menus were completely illegible and unclickable was enabling “Enable Window Animations” while also using a second monitor. The only way to interact with the menus then would be to bring focus to another window offscreen, then directly click onto File or Edit in Unreal, and interacting with the context menu (and by extension Editor Preferences window) while focus is not on Unreal. Clicking to expand these menus would not bring focus to the Unreal window, allowing me to change things. Obviously that’s not a serviceable workflow at all, so I disabled Enabled Window Animations completely to fix that problem.

In both cases the problem seems to be Unreal context menus do not like multi-monitor setups at all, and things break.

You would think every developer at Epic use multiple monitor setups, but maybe none of them activate window animations, or none of them watch something fullscreen on their second monitor, or whatever else may be strangely unique about a seemingly common configuration. I only have two screens, and my secondary monitor is on my left.


THIS IS IT! As soon as I just got the problem to happen again on my end and I was about to restart the editor like I normally do I decided to instead un-fullscreen my windows on my other monitors. As soon as I did this I could right click on things with the drop-down menus coming back without having to restart! At least for me, this seems like an issue with multi-monitor setups having other fullscreen things on them and Unreal Engine. @Orbiter7MD thank you so much for sharing this info.