Contact Shadow is showing when cast shadow is off.

To make it sure, I just created a new project.
And changed Directional Light to be movable and set Contact Shadow Length as 0.1.
Then the mesh shows contact shadow even when I turn off Cast Shadow from the mesh.

How can I turn off contact shadow from the mesh?