Download

CONSTANTLY compiling shaders!

Hello all i just compiled the latest preview release and its not fixed in that version.
Please give us an hotfix if possible.

Shader compilation starts every time Material Editor opens with output logs:

LogMaterial: Missing cached shader map for material PreviewMaterial_0, compiling.
LogMaterial: Missing cached shader map for material EmptyMaterial, compiling.
LogMaterial: Missing cached shader map for material EmptyOverheadMaterial, compiling.
LogMaterial: Missing cached shader map for material EmptyMaterial, compiling.
LogMaterial:Warning: FMaterialUniformExpressionTexture had invalid TextureIndex! (1 / 0)
LogMaterial: Missing cached shader map for material EmptyOverheadMaterial, compiling.
LogActorComponent: UnregisterComponent: (/Engine/Transient.SkeletalMeshComponent_0) Not registered. Aborting.
LogActorComponent: UnregisterComponent: (/Engine/Transient.SkeletalMeshComponent_0) Not registered. Aborting.
LogActorComponent: RegisterComponentWithWorld: (/Engine/Transient.MaterialEditorMeshComponent_0) Already registered. Aborting.
LogActorComponent: UnregisterComponent: (/Engine/Transient.SkeletalMeshComponent_0) Not registered. Aborting.
LogActorComponent: RegisterComponentWithWorld: (/Engine/Transient.MaterialEditorMeshComponent_0) Already registered. Aborting.
LogMaterial: Missing cached shader map for material FMatExpressionPreview MaterialExpressionTextureSample_0, compiling.
LogMaterial: Missing cached shader map for material FMatExpressionPreview MaterialExpressionTextureSample_1, compiling.
MaterialEditorStats: Info Base pass shader with only dynamic lighting: 61 instructions
MaterialEditorStats: Info Vertex shader: 33 instructions
MaterialEditorStats: Info Texture samplers: 5/16

UE4.1

I have same problem. Even moving non connected node around starts recompiling.
When i want to add bunch of nodes with ctrl+W, for eg 4 Lerps it starts new compiling on top of old one just increasing number of shaders to compile,
This way i can get to few thousands fast.

There really should be button to manually compile/ compile only when material is applied/ and compile only before playing.

Same issue here. Hard to compare changes when you have to wait so long between updates. Hope this issue is resolved fairly soon.

Exact same thing happening to me! Why Can’t Epic just end this nonsense live shader compilation for good? It’s ruining everything!

+1 for a fix for this. I’m avoiding working on materials as much as possible until then, it just takes too long.

Epic, can you do a quick-fix-patch or something? Just reverting it back to the old way would be fine.

Can the author of the thread make a poll so we ALL can see the numbers ? Aka “Do you want the feature removed?” YES NO

This is very annoing indead!!!

Hi everyone,

We have released a preview version of the 4.1.1 update. This contains a fix for the shader compile issue. You can find more information here: https://forums.unrealengine.com/showthread.php?4406-4-1-1-hotfix-update-Preview-now-available

If you do not wish to try the preview version, we do expect to have an update for everyone within a week. Thank you and have a great day!

Awesome! Thanks Adam, knew I could count on you guys :slight_smile:

Thanks! It’s work.

Hi everyone,

Please check here https://forums.unrealengine.com/showthread.php?4406-4-1-1-hotfix-update-Preview-now-available for the most recent update. An additional update has been made to the 4.1.1 preview. Thank you!

Can you please go into more detail on these “usage” checkboxs, what are they and how do I get to them to uncheck them? Thanks.

A feature to disable shader compiling would be still very useful.

i think he meant the top icons with name Live , like live nodes etc … i’m not sure .

I’ve very recently (as in two hours ago) started to check out the basics of the editing tools for Unreal 4, to appraise its possible use on an upcoming project.

At first I was pretty impressed by the editor, until that is I created my first material. It’s a very simple one with just 3 textures, plus a single constant as inputs. However I’ve hit the issue being reported in this thread (and in manner other places beyond this forum) of the incredible times being spent compiling, then recompiling shaders after the smallest change to a single shader (e.g. a change to the constant value).

After the material was first created the popup reported about 300 shaders being compiled. Strange I thought, but hey I’m new to this editor, perhaps it does this on the first use of the material editor in a session. But then after making a small change to the single shader, the popup reported 372 shaders being compiled. With the next two small changes to the shader, the number of shaders being re-complied was reported as 600+ then 1100+

This all took place within the first few minutes of my using the material editor, resulting in a wait of about a minute for the 1100 shaders to complete their recompile.

I have to ask… why the need to recompile such a large number of shaders, when only one had changed and why would that large (over 200) number of shaders (assuming that the number reported in the popup is correct) rapidly climb to an incredible number (over 1100) for a scene that that has minimal content of a single landscape mesh with a single material applied to it.

I can see that in this thread there’s the suggestion of turning off some “usage” checkboxes, but to be honest for me to have hit such a big issue, so fast, that seems to be so fundamental to the workflow and there is just a rough workaround has me stunned.

What’s now stunned me even more is that I’ve just noticed that the posts to this thread reporting this issue, span two years, so I’m not expecting a quick resolution to the problem.

As the editor stands there is no possibility that I can recommend Unreal 4, as an alternative to our company’s internal tech.

The version of the editor I’m using is 4.12.4

Hi Purpleivan,

If you look at the usage list (Select Material Attributes Node > Details panel > Usage) you’ll see some check boxes there. The default is to automatically update this and recompile the shaders for the material everytime it’s applied to one of these new types. So as an example, if I have a material that is being solely used on static meshes and then I put that same material on a Skeletal Mesh the material will recompile. Depending on the material’s complexity this could be a 100 or more shaders that need to recompile. If this happens for several materials it’s going to jump upwards like you point out. If you add to or alter the material you’ll have to wait for it to recompile. You can disable Live Preview and then compile once you’ve made all your changes though.

If you think there is something fundamentally wrong with the process where it’s recompiling shaders every time for this material being applied to an actor that has its use-case already selected or something that is not functioning as intended and is reprocible in a new project I would suggest posting a bug report over in the AnswerHub. You can find the details for how to report a bug in my signature below.

I remember the issue that originally was posted by this, mainly because it’s around the time I started at Epic, and this was an actual bug with shaders recompiling and then compounding on top of each other. One way to reproduce it was to go to the Engine Scalability settings and each time you changed the scalability the shaders would recompile and as you selected other settings it would add to the previous compiling shaders. This was not supposed to happen and was fixed in 4.2, IIRC.

This is the necro to rule all necros

I’m sorry, I don’t understand. I’m having the same problem, I’ve got 2,440 to compile and I left my computer overnight last night so it could finish (it did, luckily). This isn’t a feasable option to me which is a massive shame because I’m really enjoying Unreal other than this. But this makes it unusable. It’s started compiling again so while it was doing that, I followed your advice and unticked everything in Usage and then hit Save but now it’s frozen again, still compiling shaders all over again so the Save dialog is frozen permanently at 50%. It usually takes about 10sec max to save absolutely everything, so to save one material should be very quick and has been once it’s finished compiling. I unchecked the box at the top “Live Preview” and that seemed to work but the moment I import a new FBX it’s back to 2000+ shaders again. Please help. My computer is basically commandeered until this finishes.

i think i found the solution…

i was first working in ue4 with no problems at all…
and after a few weeks of good work, suddenly it keeps compiling shaders constantly…(and also my antivirus software was suddenly constant alerting me before it wants to compile shaders)

and one of the changes i made a day before was that i installed microsoft visuel studio’s (multiple versions), and a apparrently it comes with a few extra programs, one of them called “incrediblebuild agent”, its a program what keeps track of the procces you computer makes. (what I understands of it (i’m quite new to ue4 and devolping in generall))

i deinstalled incredible agent, and my problems where gone…
(live node/preview where not the problem for me, and it works quick also if they on)