Download

CONSTANTLY compiling shaders!

Everytime I used a shortcut, or change a parameter, or a colour, or ANYTHING, my entire shader recompiles.

How can I stop this? Its dramatically slowing me down especially with a material as complex as mine. Compile times are also incredibly high, so it’s not like it’s a short iteration period either.

Maybe try Material Instance Constant?

This is as I’m building the material, not while changing default parameters. Just duplicating a node (even if it’s not attached to the main tree) forces yet another recompile. Completely defeats the point of the shortcuts in the first place.

EDIT: Found a temporary fix, unchecking any of the ‘usage’ checkboxes stops the recompilation popping up all the time. Wonder if that’s by accident or design?

Oh ok…Maybe a Re-Compile Shaders button on toolbar would be nice instead of this automatic re-compiling. So once the user creates all the nodes, we press Recompile Shaders button and it recompiles.

That solution seems so obvious that it should be therenow.

My shaders are compiling and I’ve not EVER opened up the Material window. I’ve just been trying to follow the tutorials to drag and drop materials on things and first it locks up, then the material goes to the default shader and says "Compiling Shaders) in the lower right with how many its gotten through. So since I can’t put shaders on anything, I’m kind of at a standstill until it’s done… whenever that’ll be. It’s on Shader 445 or something crazy like that.

…hmm… After a bit of waiting, I notice that the number keeps going up and down (445 to 415 to 420 and just around there.) I’m not sure what’s going on, but I don’t think I did anything to warrent an odd action like that. I’ve never even edited any of the shaders I even tried clicking that left pointing arrow in the object shader elements so I wouldn’t have to drag it, same result though.

Hopefully this gets fixed.

I noticed when I create a material that it has just for Diffuse, Normal and Spec (using vectors and bitmaps) something like 720 shaders to compile, which is a handful of minutes to wait every time something is subsequently changed in the material. This doesn’t make me a fan of the material editor.

I closed both UE and it’s launcher and tried again.

This is how it’s SUPPOSE to work.

https://www.youtube.com/watch?v=Yb4uu2NEC0E&list=PLZlv_N0_O1gbQjgY0nDwZNYe_N8IcYWS-&index=3

But when I open and run it, the vector 3 node doesn’t even update. After the ten years of compiling, it’s updated… but god forbid you wanna change the color from orange to a SLIGHTLY darker orange… then you have to wait again. … and it’s a LONG wait at least for me (twenty minutes maybe)

See if you can follow this tutorial.

Clearly everyone isn’t having this issue. I’m trying to look for an event log or something that says what’s happening, but I don’t see it in any of the developer logs or error checking things.

I have 8 gigs of RAM with a Q6600 CPU (4 cores) with an NVIDIA GTX 560 Ti (2 gigs of VRAM)

Hopefully this is fixed in 4.1. I can run everything else like all the maps and stuff just fine, so it’s kind of upsetting that I can’t get this to work, because I was really excited to use this engiine.

Hey, what are your computer specifications?

After some more tinkering, I think the computer may just be too slow (CPU wise) It probably just takes more calculations. If you check in the computer hardware thread, you’ll see my CPU is a dual quad core 2.4 GHz, but no hyper threading. I started a new project and it takes the material about 10 to 30 seconds to update. I think it’s just my CPU’s not fast enough or something… although I don’t see why the GPU doesn’t do that, but that’s a whole different matter.

This will be a huge issue when there’s a level with tones of materials to compile since I think it’s trying to compile everyone single one.

Just something I noticed.

Hi guys,

Zak Parrish and other guys from Epic Games run high-end-specs machines that’s why you don’t even notice how shaders compile (actually they are - you can notice how the yellow text in the upper left corner of the Material Editor window disappears for a second-two when Zak plays with the material, and that is for the shaders compilation).

I have a middle-specs laptop and that is not taking a long for compiling shaders. I run an engine compiled from the latest sources (master branch), so probably I have less bugs. You can also try to update your video card drivers if you haven’t done it yet.

This has nothing to do with low PC specs. I just compared the behavior from 4.0.2 and 4.1 and there has to be something gone wrong in 4.1. In 4.0.2 when I disconnect a link on some node it just updates the shader that’s open and that goes really fast. However in 4.1 whenever I disconnect a link, or even when I just open the material editor it starts to compile seemingly all shaders and just keeps queueing them up again and again whenever I do anything in the material editor. So you get those hundreds of shader compiles counting down with every little change, eating up your PC power for no reason at all. Sure hope this will be fixed fast, because it turns working on materials from superfun to painful.

Hmm, I seem to have the exact same problem… The MaterialEditor is slowed down horribly by this recompile-thing - it’s basically impossible to work with it. It takes like 40 seconds just to recompile the material if I create a blank material with just a simple color in the BaseColor-Channel.
OK, my hardware is not the best (AMD Phenom, 4x2.2 GHz, 4 GB RAM, HD6770) but the whole UDK is running surprisingly well and - guys, honestly - compiling a material with a simple color in the diffuse channel should not take that long??? In UDK3 muuuuch more complex materials could be done easily on my system…?

Is there a fix coming for this? This must be some sort of bug…?

Read the rest of the thread, Disable updating your nodes in order to set up your mtl then do a compile once u want to preview.

Also this is a next gen engine don’t compare it to udk. It’s like a new born baby.

My PC doesn’t meet minimal requirements yet, but only editing materials makes huge problem, as it’s recompiling shaders each time I try to change something. I really love this new engine, but this issue preventing me from making more advanced materials.

Iam aware that the engine is new but still I have problems believing that such a “simple” thing can have such an impact on the overall performance…
But nevertheless - the “LiveUpdate” and the “LiveNodes” functions are both disabled and still it takes ages to recompile materials when I create, modify or connect nodes…

Same here. Everytime i open a Material it start´s compile, between 90 and 200. When its finish and i open the same Material it start compiling again.
It must been an issue with 4.1, 4.02 runs without compiling “problems”

Here are the same problems even when i just open the Material editor it starts to recompile 200-300 shaders.

The material editor flags the current material as dirty on some events, it seems in 4.1 opening the material, mistakenly sets the same flag, hopefully it won’t be hard to create a QFE in the meantime, till it gets fixed for the next major update.

Can you please tell what CPUs you are using? Mine (Phenom 9550, 4x2.2 GHz) is rather slow and this might be the reason for this.
Iam not sure whether to wait for an update or to upgrade my CPU…

But like this it’s just really a pain in the *** to work with the material editor… Which, on the other hand, is one of the most important features of UE4…

Hello Hackmet
My CPU is a i7 4770K and GPU is a ATI 7970.
I cant work either with the current editor just becouse making a new material costs too much time to just test some stuff out.
Ps didnt had the problems in 4.02.

It’s nothing to do with my systems performance, which is actually pretty good. (i7-3820K & GTX 560 Ti ‘448’ Edition).

As I said above, if you uncheck all of the flags in the ‘Usage’ section, the problem seems to go away, and it won’t compile until you recheck them and save the shader. Changing colours in parameters causes a recompile though, which is utterly frustrating. Iteration time in the Material Editor in general is pretty poor, and we never had the issue in UE3. What’s worse is when it does compile the shader, you are presented with the default material, making it incredibly difficult to compare your changes to the previous ones anyway.