Connect to dedicated server remotely

I followed this guide here: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums for windows and it worked perfectly. I am now trying to go from opening a level with my localhost, to opening a level with my public IP and I am having some issues.

I replaced Level Name with my gateway’s public IP. I recompiled and saved the level, and repackaged the project. I then went to my router’s settings and set up my desktop with a static IP (, and set up port forwarding for port 7777 (I’m pretty sure I have done this part right, as I have a PLEX server that works remotely). I then went to my firewall, and ensured that all incoming/outgoing traffic onto port 7777 would be accepted.

After launching my server.exe as I did before I get the following output: LogInit: Build: ++UE4+Release-4.17-CL-0LogInit: Engine Version: 4.17.2-0+++UE4 - which seems fine to me. But when I open my game.exe I get a blank screen, and no new output on the server log. So I tried to see if the port was open using, and testing port 7777 I get that it is closed. I check if my PLEX port is open on this site, and it is open, and my PLEX is setup the same way unreal is.

I then check netstat -AN from the command line and I notice that PLEX has the following entry: TCP ESTABLISHED and my 7777 has the following entry: UDP *:*

I am truly at a loss right now, I feel like the issue has to be with the unreal server exe as my PLEX connection seems to be fine, but I have followed every part of the dedicated server guide.

thanks for any help