Confused by PostProcessing, cannot get my settings to work?

I’m trying to get postprocessing to work. It feels like I can get Motion Blur working, and I’ve been able to change DOF through Blueprint. But now I cannot get Scene Color to work:

I’ve added a PostProcessing Volume to a test world, and set the properties as shown in the first picture. Scene Color did not work. I went to the player camera and tried changing those settings (second picture) but it still won’t work.

I looked at the PostProcessing map in Content Examples and I couldn’t see anything different between that and mine.

I loaded the Example Map and tried these settings there, and they worked.

[This may be an unrelated issue, but additionally I cannot get materials to bloom when pushing their RGB values over 1 - they just stay flat without the expected glow.]

Did I break my project settings? Any ideas on how I can get PP working again?

Many thanks for your time,
Jon.

Hey Rehven,

A couple of things couple be affecting the issue you are experiencing. Firstly have you tried building your lighting, and also were you trying both of these settings at the same time? The colors could be nullifying each other if that is the case. Let me know if you have done both of these things and are still experiencing an issue.

Regards!

Hurley

Hello Andrew.

Yes I’ve tried rebuilding lighting (on all qualities).
No the settings were not tried at the same time.

I’ve made a New Project and confirmed that what I’m doing is correct - it works in the new project.
I’ve made a new level in the problem project, and the Scene Color change is ignored. I think we can safely say that something in the problem project is broken, but I don’t know where to look.

Thanks for your help!

You are welcome,
One thing to try go into your “Project Settings” under the “Edit” menu and match the default values in the image below with your problem project.

Let me know if this changes anything!

Hurley

I don’t have that Default PP Settings section:

I’m on 4.4.3, is that in the Preview?

Also you mentioned you were setting up DOF through Blueprints. If you are still utilizing this blueprint in your project this could be overriding your ability to use scene color within a Post Process Volume. Try temporarily disabling your PPV Blueprint and checking to see if the Post Process Volume works afterwards.

Hope this helps!

I’ve stripped everything PP-related from all Blueprints and restarted the editor. PP modifications are now limited to volumes in a level (Unbound to set default PP, Bound in a particular location).

Problem still exists.

This is so wierd and frustrating :slight_smile:

My mistake, the image I posted was from the 4.5 preview, but if your settings are not different from mine in 4.4.3. (which they are not) then that is not the issue anyway. Can you reproduce the issue in a template project and upload that in order for us reproduce it on our end? Or if you are okay with it send us the problem project?

Thanks again,

Andrew Hurley

Of course I can send the project. How do you want it? Feel free to email me if you need to.

All we need to test your project are the uproject file, the content folder, and the config folder. Just copy those into a new folder and zip it to a compressed file. Then you can attach it here on the AnswerHub. If the file is too large you can always just upload it to DropBox and post a link to the upload location as well.

Thanks again,

Hurley

Hopefully I did this right:

Maps/TestMaps/JonTest is a good place to start looking at things, I guess.

Thanks Andrew.

Hello Rehven,

I downloaded your project and was able to open up the levels and examples you provided. I followed your suggestion to use the JohnTest level and was unable to get the post process volumes to work as well. I went into your other levels to see if it was specific to the level at all, but with no success either.

There was something I did notice though. You mentioned you were messing around with Depth of Field in Blueprints on your original post, and when changing the settings of the PPV (Post Process Volume) in the JohnTest level, I was able to get the Depth Of Field to work correctly. However, this was the only setting within the PPV that would function, and much like you said the scene color and other settings do not render.

I am wondering if this is related to your Blueprint with the Depth of Field at all. If you could try and reproduce what I tested and see if there are any associations or dependencies with your Blueprint and the functioning Depth of Field, we could start to narrow down the reason for the issue!

Thank you!

Andrew Hurley

Ok Andrew, I’ve been through all the Blueprints in the project and disconnected/disabled any that try to change PP settings; as far as I can see, now only PP volumes are being used.

You’re right, the bound PP volume in JonTest definitely displays DOF and Motion Blur effects, but nothing else.

Something has occurred to me, too; I’m using a PostProcess material to show object outlines (Materials/Snow/PP_Outliner_M and PP_Outliner_Inst). Could that be affecting scene color? I just removed this Blendable from the Global PP Volume and tested but it had no effect, although I may be doing something wrong there.

Hey Rehven,

Good news, I was able to figure out with the help of another set of eyes, how to get your PPV settings to work properly in your Snow Project. I have steps in order for you to do so as well! A couple of quick notes before I list the steps, and reasons as to why this issue had occurred. If you had a previous version of this project built in a different version of the engine and converted it over, the dependencies as well as settings might not have been translated correctly and were either ignored and/or overwritten. That being said there were a lot of redirects in your DefaultEngine.ini file that could have also caused the issue to occur. Follow these steps and go back into your project to see the visual changes.

  1. Go into you Unreal Projects Folder
  2. Find your Snow Project and open the Config file folder
  3. Find your “DefaultEngine.ini” file
  4. Right click the file and click on properties
  5. Be sure the check box “Read Only” is unchecked so you can save the changes you are about to make to the file.
  6. Make a copy of the “DefaultEngine.ini” file and send it to your desktop just as a safe guard
  7. Now, open up the file and delete everything except for your “[URL] GameName = Snow”
  8. See images for reference
  9. Also notice all of the r. files as well as the redirect files. These are what is causing your issue.
  10. Be sure to save the file after making your deletions/edits
  11. Close the folders and open up your project.
  12. The default level will now be the template and your UI layout will be reset, but don’t panic just open up the level you want to test. I suggest the snow level with the SnowCat matinee.
  13. Find the PPV and edit the scene color to see the effects!

Cheers!

Andrew Hurley

This completely fixed my problem; I can confirm that PP Volumes in the world are now working again!

Is there a reference for all the r.* settings that had crept into the project? If I know what they translate to, maybe I could trace who (on my team) messed around in the settings file.

Thank you so much Andrew and “other set of eyes” :slight_smile:

If there is a reference I am sure it would be incredibly hard to locate, but no problem! We are glad to have fixed this issue you were having! The r. files are all just settings that are being pushed to your project. So if you wanted to, you could just look at each individual r. file name and see what setting that affects.

Cheers!

Andrew Hurley

same issue: screen color would not work - this was the first PP we were attempting to use in a new-ish project.

I used the above process to fix, but followed up and nailed down the r.* settings that needed to be fixed to actually resolve this issue (instead of just blasting everything)

under the section [/Script/Engine.RendererSettings] if either of the following are set:

r.MobileHDR=False
r.DefaultFeature.Bloom=False

then screen color (and presumably many other settings) will not function.

set these values to true via edit->project settings->rendering
(or manually edit the ini file)

Thanks! this post save my life!