Download

Confused about PBR

I think I’ve totally confused myself by learning PBR, Marmoset and Unreal in the space of two months. Would really appreciate if anyone could look at the image and see if you can find where I’m going wrong here.

  1. I’m really super confused as to why my metal (mostly the frame around the door) appears black and tiny super reflective bits.
  2. I recall that with PBR metal is 1 and non metal is 0, no inbetweens. It either is or isn’t metal. Yet I want my stone to be a little bit shiny? real life rock can be shiny too can’t it?

note : So with metallic and spec slots, I’m plugging in the green channel of my mask. This is basically pure white for only the metal in my texture.

note 2 : I say diffuse but yes, I mean albedo. Old habits :slight_smile: I tried making the albedo much brighter and more flat but it looked terrible, probably because my spec/metal/roughness are set up incorrectly so I will go back and improve the albedo once I know what’s going on.

You need to go into World Settings and change the the Environment Color to something other than Black. Light gray or brighter should work.

World Settings > Lightmass > Environment Color

Its really quite simple. You can have shiny or rough wood, stone etc, that’s controlled by the roughness map. If you have 1 (or white), its 100% rough and won’t reflect anything, it is 0 (or black) it will reflect a lot.

Meatless effects the colour of the reflection and the albedo. If metallic is 1 (or white) then the Albedo will be black, and the reflections will be colourised by the albedo (for instance a yellow metal like gold with yellow highlights. If the metallic is 0 (or black) then the Albedo will be the colour in the texture you supply.

Thing you are missing in your scene is a reflection probe or a sky so supply the reflections that work with PBR. and that is why your metal is black, basically metals are black albedo with a lot of reflection, you need the reflection environment to fill in the missing information.

I suggest you to not use specular channel unless your texture looks brighter or darker for your taste. Even for them simple scalar vectors should be enough for most objects.
It’s all roughness now, even on maps with no screen space reflections.
And keep on mind ambient occlusion has zero effect on dynamic lights.

I think it looks full black cuz it reflects the black area but I am not sure.
Try to put your object in closed cube or something, you may also the change the environment color.

Ah of course, I deleted the default skybox from the blank scene I created the project in. Any idea how to get it back? I suppose I could copy the asset, materials and textures into a new blank project. Thanks for the info!

To get the skydome back, go into the Content Browser and select “View Options” (#1), then from the menu enable “Show Engine Content”. With this enabled select the “Engine” folder (#2) then in the search box at the top type in “bp_sky” (without the quotes) (#3).

All you need to do then is select the asset and drag it into the viewport, you may need to adjust some of the values using the details panel to get it back to looking the same, but this is a simple way of doing it. :slight_smile:

That’s great, thanks. So that indeed was a big part of the problem. I also tried bringing in a reflection sphere but it made everything too light (even at a super low value) so I deleted it. I’ve tweaked the textures all day, still doesn’t look good but much better than before. I find the albedo doesn’t really do anything, even if it’s dark or light, saturated or not…something else just overrides it and make it feel glossy/waxy. Even though it’s 0 value metal and about 0.9 rough.

I would definitely disconnect the specular, I think it defaults to .4 or something which is the right thing to do. Roughness is also ideally a single channel but you seem to have greyscale in there so thats OK. Your Albedo should be much brighter, in a PBR situation you want the pure Albedo which is much brighter than you would think. I personally would have the rocks rougher too - brighter in the roughness mask

Rock is pretty rough unless it’s wet

Your Albedo / Base Color looks really dark try to brighten that up by a lot. Also when dealing with Metallic objects they should be either Metallic or nonMetallic, 0 or 1. Metals, for the most part*, do not do in between values and always use extremes like 0 or 1. If your Metal is to dark you need to brighten your Albedo / Base Color instead of messing with the Metallic value. Also disconnect your Specular as you do not need it. The default of 0.5 will work for 99% of cases. If you really want to use it you can put a cavity map in there to help shadow small areas that the engine can not because of their size. You also need to use reflection spheres in your level as that is a key part of the PBR system. Not using them because they are making your object look wrong is not the correct way to go about fixing the issues you have. If the reflection sphere are giving you issues you need adjust your Roughness map to fix that.

*You can use in between values when using a Texture to show the transition between two different Materials like going from a rusted metal to a painted metal. However if you are using a solid metal just use a 1 and not something else.

Putting in my 5 cents here :slight_smile: Looking at Metal texture it is clear that the gate’s frame with some other elements defined as being “fully metallic” (white value of 1). Yet in the Albedo map these elements are way too dark, as Sam Deiter mentioned above, with RGB value of 51,51,51. The PBR theory says that if the material is metal (in Metallic/Roughness workflow, which is used in UE4) and defined as such in Metallic texture map, then your Albedo map should contain reflectance/specular value for this material, while actual albedo will be set to almost black by the shader. Generally this means that if some part of your texture is metal, then Albedo for this part should be bright. For pure Iron it will be something close to RGB(197,197,197).

So, if I’m not mistaken, there’s actually two options for making it look correct from the perspective of PBR: if your artistic intent was to show those metal parts as being made of cast or forged iron, then those parts shouldn’t be defined as metal in Metallic texture map, as forged iron doesn’t have “metallic” properties on its surface. It is a dull, rough surface with properties close to insulators (non-metalls). In this case only the Metal texture map should be corrected to reflect that.

The other option is available if you want the gate’s frame to appear as actually being made of Iron (plain one). In this case it is necessary to correct Albedo values to make it brighter, with RGB(197,197,197) or something around that. Note that this is not a rule, but more of a baseline or reference. In real life we hardly see any pure metal, so it may as well be something a bit lower than that.