Configure detour AI behaviour

I am using Detour AI Controllers and currently working on simple group formations.

When formations get tighter, my pawns seem to block each other somehow, but not through actual collisions.

I believe it is somehow related to the detour logic as their paths become much tighter when not using Detour Controllers (although they then get stuck very often).

Is there a way to configure detour behaviour? Like reducing some agent radius so they can stand closer together?

Thanks in advance and cheers!

To make things a bit more clear, “tight” formations, doesn’t really mean tight. And sometimes my AI struggles more than 10 seconds in situations like this:

The last one clearly has enough space to pass between the ranks, but he doesn’t. He ends up jagging around there and finally goes around.

Alright… As I was typing the comment, I thought about avoidance settings and I looked it up and actually had RVO avoidance activated on the pawns Movement components… my bad.

With RVO turned off (or maybe just optimized better than now) the results are much better.

Still, are there means of configuration for Detour AI?

Hi, what I know about is project settings → engine → crowd manager. I only ever changed Max Agents (and Resolve Collisions if its not enabled by default) though.

Yeah same! I did play around with the settings a bit but it was quite aimless and I didn’t notice any changes really…