Compositor SteamVR Errors after launching Unreal Engine

Hello, I’ve been trying to use VRPreview with the VIVE for a while now without any success. The SteamVR tutorial works fine. When I launch Unreal Engine (4.9) while SteamVR is Active, SteamVR will give me an error message that Compositor is not fullscreen and become unresponsive. Any ideas?

Have you tried running UE4 editor without the SteamVR drivers running?
I believe UE4 launches it’s own version as soon as you start the editor.

The plugin is enabled, and I can run VR preview without SteamVR running but all I see through the VIVE is the “white room”. I can move the HMD and see in the desktop duplicate of my game that the the head tracking is working, I just can’t see anything through the head set :confused:

I have the same problem and what I do is launching the Steam VR tool and then launching Unreal. In some point it always complains about not been fullscreen but it works just fine.

Try not having windows in fullscreen a part from the SteamVR tool, not having windows out of the main screen and when Unreal opens the window with the game click with the mouse on it.

Hope it helps.

Btw, I updated to the latest version of SteamVR this week and now I need to unplug one of the sensors because it gets confused and it doesn’t detect any of then.

Try this:

Sorry to resurrect such an old thread but I’m having the same issue and haven’t been able to solve it. Was anyone able to fix this? how?

I found a better solution, i had similar issue, After updating my Video Drivers and putting SteamVR into direct mode it works fine without any problems, and you no longer need to customize the display thought.

Enabling Direct Mode solved my problem. Thx!

Look for Engine\Plugins\Runtime\Steam\SteamVR\SteamVR.uplugin and set “EnabledByDefault”

1 Like