Component properties revert to defaults in cooked data

We have an issue with a blueprint class which inherits from a c++ base class defined in our project.

When playing through the editor, the class is created correctly and behaves as normal, but if we cook the data using the UnrealFrontend tool, properties for some of the collision components within the class are missing, causing gameplay issues.

The components which display this issue are both Sphere Components.
When the class is spawned, both components have their collision profile and sphere radius properties set to the defaults, preventing their expected behaviour.

We have tried everything we can think of to resolve this issue; deleting the blueprints and rebuilding them from scratch, renaming the problematic components, cleaning and rebuilding intermediate data, etc. Nothing has worked.

There are other blueprints which inherit from the same c++ class and parent blueprint which do not currently exhibit this issue, but making changes to their sphere components will cause this issue to start occurring for them also.

I have tried to debug the cook process but found that if we cook the data by running the editor through Visual Studio with the appropriate command line arguments (instead of launching the UnrealFrontend tool) the cooked data does not exhibit the missing data issues.

I do not understand enough about the cooking / serialization process to be able to guess at the cause without being able to reproduce the issue in the debugger.

Presumably our cooked and source assets might help illuminate what is going on, but unfortunately I am not aware of any way to export or view uasset files in a human readable format.

First seen in 4.12, but it appears to still be occurring in 4.13.

I can provide source and cooked uassets for comparison.

Thanks in advance

Hi Nathan,

Do you see this happening with other components, or only with the sphere component? If you have a sample project that demonstrates the behavior you have mentioned, that would be very helpful since I am not sure I would be able to accurately reproduce this without more details about the setup. If you need to provide anything privately, you can [send me a PM][1] on the forums.

Hi ,
so far we’ve only noticed this issue with properties on the sphere components, but since they are used for collision it’s fairly obvious when the values get reset to the defaults, it’s possible the issue is happening elsewhere too but it hasn’t been observed.

I will try to reproduce the issue in a clean/sample project, in the mean time would it helpful to provide you with our source and cooked assets for these blueprints? Do you have some kind of uasset viewer that might shed some light on why certain properties are missing in the cooked data?

Hi Nathan,

If you can provide the source code for the base class and some screenshots showing how your Blueprint is setup, I may be able to create a similar Blueprint myself and, hopefully, reproduce the behavior. Unfortunately Blueprints that are derived from a code class don’t transfer between projects, so I wouldn’t be able to open the actual .uasset.

Hi Nathan,

We have not heard back from you for a few days. Do you still need help with this issue? I will be marking this post as resolved for internal tracking purposes, but please feel free to add a comment and re-open the post if you need any further assistance.