Complete performance meltdown

I am forced to attempt to reinstall the editor has become totally unusable with all versions. Moving things lags so heavily placing objects is a very time consuming processes. The editor freezes an upward of 2 to 3 minutes and it takes huge chunks of cpu usage just idling… This has been going on ever since the 4.5 update… I posted in the forums and it was suggested I post it here.

Total instablity from 4.5 and up - Feedback for Unreal Engine team - Unreal Engine Forums I have to reinstall and hope for the best because I am loosing time. I work with a small team and speed is of the essence, sadly the editor has been slow for along time…

OK, I read your post on the forum and the only thing you actually said that had any relevance was:

“Due to graphic and memory lag (stuff we don’t care about) the toolset randomly re-selects geometry and meshs after a freeze lag.”

Probably you were clicking on stuff while it was lagging and after it got through whatever was clogging it up it tried to process all your random rage clicking. Just a guess.


“ALSO I have submitted about 10 crash reports for attempting to move content out of the root game content directory into sub directories because importing outside of the content directory messes the assets up.”

For this, make sure you clean up redirectors when you move assets around. That can cause a LOT of instability issues. You can clean those up by making sure that you run “FixUpRedirects”(right click on folders in your content window).

If you would like to post some crash logs or tell us what you are actually trying to do when the performance issues hit, most of the community would be glad to help. However, please feel free to dispose of all the ranting, boasting, and threats of rage quitting and what not. They aren’t very useful and won’t help us solve your issue.

What version are you using?
Binaries or did you build it yourself form github?
Does this happen on a new project?
Is this a project that was “upgraded” from an older version?
What are you doing, specifically, when it begins to lag out?
Do you have any crash logs or anything from when the game crashed?
Does it crash straight from the editor, or when you try to run your project?


wow congrats I have written about 3 responses attempting to say the same thing different ways because you obviously have a very low understanding of English. I just don’t have the right words you will understand. Epic feel free to close this question I am done with answer hub.

Folks, please keep it civil, there’s no reason for personal attacks.

My UE just crashed after clicking “FixUpRedirects” :slight_smile: I also have some problems with stability (crashes 3-5 times/day) but in my case it might be because of converted (from 4.4) project, so i’m just trying to endure it for now :slight_smile: So yes, UE 4.5/4.6 has stability issues, but Drixil, if you want any improvements in next versions, you should provide more information to help devs to spot these weak points - and be more patient bro. Patience is a MUST-HAVE skill in game dev :smiley:

As an alternative while waiting on Epic, have you tried compiling from source code (epic/promoted or epic/master branches)?

Both branches will compile and run (as of this writing). I generally run epic/master but since I do not develop anything critical it’s not a big deal if it gets broken. :slight_smile:

You could try epic/promoted as that is the branch used internally by Epic’s artists and designers. It has some QA testing done on it but not release ready.

I do not suggest you run this in production, only to check if your issues have been resolved upstream.

If you need VS 2013, you can get the Community Edition from Microsoft for free at Download Visual Studio Tools - Install Free for Windows, Mac, Linux

I have actually fixed the problem for now. I had to reinstall which really isn’t a fix. I am actually thinking about building from source and going through the code base to see what is going on with the memory. I am pretty sure it was memory issues with the tool set itself. Seeing as how after reinstall the problem erased itself. I am going to keep trudging on for now and see if the problem happens again.

I have seen this issue in the past with other proprietary engines I have had to work with in the past; where various issues occurred the same way. Generally in those cases the developers had not handled functions properly or simply overlooked something, causing loops that got picked up by garbage collection but it was still be referenced in the code that was being executed. Not sure if this is the problem here seeing as how epic’s codebase is very clean from what I have seen. It doesn’t have the memory issues out of the box. They began happening after time.

Glad you were able to get it sorted out. The engine is still labeled as ‘experimental’, so these types of issues are pretty much expected. The instability is the price of being an early adopter. As I mentioned in my original post, one of the things that causes a lot of problems, especially if you move stuff around a lot, are redirectors. So be sure and clean those every time you go shuffle things around. It is also a good practice to start and stop the engine after doing so to make sure all that stuff gets cleaned out of memory. Good luck with your project.