Compiling the VR Editor

I think I managed to compile it ok but for me the Play->VR Preview button is greyed out.
Like it is when you’re using an old runtime. But I do have 0.8.0 installed and it has worked fine before.

Not sure what I might be doing wrong?

Also, I was trying to get the Hydra plugin so I downloaded the new VR-Editor version and it seems to be installed ok when I go to the plugins window inside the editor.
But I can’t seem to find for example the HydraCalibrateActor.

Anyone got an idea what I am missing?


Had the same problem. What worked for me was to use the GenerateProjectFiles.bat after I put the HydraPlugin in and compiling the engine again.

Next time I launched it, preview wasn’t greyed out and VR editor worked.

Hmm…that did’t work for me. I tried that and also again with doing a ‘clean’ first.
You are using your pre-compiled version of the vr-hydra plugin? “hydra-ue4-vr-editor-v0.8.6.7z”

Not an emergency this of course! (but it would be awesome to try it! :slight_smile: )

So I was missing the runtime folder from the plugin I’ve updated the release here: Release VR Editor Release · getnamo/hydra-ue4 · GitHub

try the hydra-ue4-vr-editor-v0.8.6-2.7z, GenerateProjectFiles.bat and compile.

Once it has been compiled, open the editor and make a new blueprint project. Once the project loads check that the hydra plugin is enabled, if not enable and restart. Then hit play to calibrate while in a T-Pose (bumper + trigger button on any hydra). Once that’s done you can exit play and enter the VREditor.

Let me know if that works.

Thanks I just tried that now. I think I must be doing something else wrong as it is still the same.
The Hydra plugin seems loaded fine but I cannot find any hydra classes when searching in engine.
And the Play->VR Preview button is still ghosted, which should be unrelated to your plugin.

I’ll have to go back and see if I missed a step or something.

Does this look ok for a pull/clone command to get the engine?
(I do get that new ‘Toggles VR’ button on the top shelf )

EDIT: Sorry I just found the HydraCalibration node. I looked in the Modes->All Classes which was not right I should have done a create new blueprint from class, then I found it!
Just need to figure out that VR play button thing now.

EDIT2: Ah…reading the VREditorPreview.pdf again explains it,

Which is weird, because I’m running 0.8 and it works (but it didn’t before?)… It’s all a mystery atm.