Download

Compiling Shaders doesn't work (stuck with no progress)

Hi,
Since 4.21, UE4 shader compilation simply doesn’t work. Whenever “Compiling Shaders” notification comes up, it stays there forever without counting down the number of shader to compile.
Looking at task manager, there is another UE4Editor.exe process that is “not responding”.
I suspect some local configuration (perhaps something stored in user directory) can be the problem.
The engine is unusable currently for me.

If anyone has any help or suggestions, I would appreciate it.

Thanks

I have the exact same issue.
I was using UE4.22, recently installed UE4.23. I’ve tried using another version of UE4 such as UE4.21 & 4.19 which used to work fine. Same thing now.

I have uninstalled all versions of UE4 and reinstalled. Even rebooting the machine. Created one of the sample projects included with UE4 and the “Compiling Shaders (116)” notification comes up and it just stays there forever without counting down. Have had the PC on now with this message for over 24 hours. Any ideas people?

After searching for hours on google and the forums; I found the solution.

  1. Open the file “C:\Program Files\Epic Games\UE_4.XX\Engine\Config\ConsoleVariables.ini” in any text editor.
  2. Find the line “; r.XGEShaderCompile = 0” and remove the “;” at the beginning of the line and delete it.
  3. Then just restart the editor.

After restarting the editor “Compiling Shaders” starts working properly again.

3 Likes

probly jst lag… try nt fr broadcast while building world, or if u opn windows, jst close it… should hv no problems… i use UE fr like 3-6hours per days fr learne, no problem at all, even if compile 1k texture or shaders… but a bit lag when it come to lighting or animations, whch why i use blender first, then jst import to the world

dyd jst now: https://www.facebook.com/AlexAkYwh95…0694087913858/

still learne project 10 lvl 1
ignore the errors frm video, should use 2 windows, but i use 1(viewpot view) XD

My man, you are the real MVP.
This solved my problem, shaders are compiling now, thank you very much.

2 Likes

Thank you **Dekrayzis2015 :slight_smile:

I had the same issus in 4.24 when I start a new top down template **

In 4.24.1 the line you are looking for is

It’s missing a space, it eluded me b/c i was using ctrl-f XD

I have another problem. Suddenly, my shader is not compiling at all. I have a landscape material that was compiled again and again and now nothing happens and my landscape went all default material. I did nothing to the material at all. Nothing shows up on my screen, no process starts, I have 4.24.2. All this codes and all this fuzz and still there is no stable SOFTWARE in sight…

type normally it’s hard to understand you

2 Likes

This also resolved my issue big time. After I tried installing 4.25 compiling shaders started freezing and crashing my computer. I wasn’t even able to use the Materials editor without it crashing, and couldn’t get any previews done and my landscaping was a joke too.

One simple deleted semicolon and we’re back in business. :slight_smile:

Removing the semi-colon is not an actual fix right ?
All it’s doing is not allowing the shaders to compile.

It’s just a workaround to minimize the time, what if someone actually want the shader to be compiled ?
I’m sure there might be other options to force compile the shaders, but what is the significance of this option then ?

YES! Thank you! I’ve been struggling with this issue for a while now. (Since 4.19?) I use an Intel Core i9 7980XE at work which has 18 cores - 36 logical and until I found this fix I was stuck only using a couple of cores to compile shaders. Now when I open task manager I see it using all 36 and 100% CPU usage!

Tried removing the semi colon and It seemed to be helping but just gets stuck at this…no progress and seems to stop compiling.

.

It’s not compiling. This is another issue. Your landscape material. Google for “checkerboard landscape ue4”.

Thanks man!!

This doesn’t seem to work with UE_4.26 as no shaders are compiling and everytime I save a material the editor freezes however this problem can be fixed in all versions prior to 4.26 but is there an additional line or something? How can I fix this problem in 4.26?

3 Likes

I just switched to 4.26 and had the same problem. Started playing around with settings in the consoleVariables.ini file. Seems have to remove “;” from the lines with r.ShaderDevelopmentMode = 1 & r.XGEShaderCompile = 0.
Shaders compiles slowly but it doesn’t appear to be stuck anymore.

1 Like

In 4.26.2 I had to remove the semicolon before “r.XGEShaderCompile = 0” AND “r.Shaders.AllowCompilingThroughWorkers=0” then shaders compiled after restarting the Editor.

1 Like

Me Too this was the only thing that worked after hours of struggle. However I would like to actually compile my shaders in order to submit a build demo. Does anybody know a workaround for unfreezing slow compilation and still making sure they actually compile? I have an I9 and 3080-ti so I can’t imagine its my hardware especially since the project I am working on is not particularly graphically intensive. If anyone can think of anything I would very much appreciate it! Thanks!