Download

[Compatibility List] Unreal 4 - Hardware Feedback

Hello guys,
I am experiencing an exchange of PC because my current notebook (one MBP), is not holding run Unreal 4, I decided to create a thread where people could post the settings of their machines and a summary of how the Unreal is running them with this, users who want to build a PC only to develop using Unreal, had a small hardware guide.
If you can post following the following model:

======= Username =========
OS: <Windows/Mac>
Type: <Desktop/Laptop>(If you find interesting, add model name)
Processor: <Processor model>
Memory: <Ram amount>
Graphics: <Graphic Card Model>
Average fps: <Average fps you can reach the editor>
Settings: <Special settings you have made for a better performance in the editor>
Notes: <Comments you wish to make>

And as they are posting, I will updating this topic.
Following is the list:

Hardware Feedback List

======= Weskey =========
OS: Mac OSx 10.9.2
Type: Laptop (Macbook Pro 8,1)
Processor: 2.3 Ghz Intel i5 Sandy Brigde
Memory: 8GB
Graphics: Intel HD3000
Average fps: 4~5fps
Settings: I disabled Tonemapper in viewport’s Show->Post Processing menu.
Notes: At first I was running at 1~2fps, I disabled Tonemapper, and he went 4~5fps, then tried to disable all other post-processing effects, but the average fps, continued this value.
Try to edit the level is a pain, but it is possible to work quietly with blueprints.


Tips

======= JammyJBW =========
OS: Windows 7 64bit
Processor: Intel i7 2.3ghz
Memory: 12gb
Graphics: gtx670m
Average fps: 20~30
Settings: Haven’t fiddled with the default settings
Notes: I’m using my ASUS G75VW rog laptop to use the engine. The fps is usually fine (unless there are particle-intense scenes) If I notice any lagspikes I OC my 670m from 620cc to 700cc and it perks right up.

======= Hellcat =========
OS: Windows 8 (“8.0”, not 8.1)
Processor: Intel i7 @2.5GHz
Memory: 16GB
Graphics: 2x nVidia GT755M
Average fps: ~30fps with the scaling options all set to “Epic”
Settings: Everything on default
Notes: I’m using a laptop, not a desktop PC, UEd usually spread over two externally connected monitors; working with the editor is super smooth, no reasons to complain

Interesting. I have the same MBP and couldn’t even get the editor to load (maybe I was just impatient although I was waiting for about 5 minutes before giving up).

Other than that I have:

======= MCam =========
OS: Windows 7 64Bit
Processor: Intel i5 @ 2.53GHz
Memory: 8GB
Graphics: Intel HD 4000
Average fps: 4~5fps
Settings: Default
Notes: Everything just lags :slight_smile: Even the blueprint editor.

AND

OS: Windows 7 64Bit
Processor: Intel i5 @ 3.2GHz
Memory: 8GB
Graphics: GTX 650
Average fps: ~30fps
Settings: Default
Notes: No complaints.

Here are my laptop specs:

======= fighter5347=========
OS: Windows 7
Processor: intel i7-3610QM
Memory: 4 GB
Graphics: Nvidia Geforce GTX 660 M
Average fps: around 30
Settings: no special settings -> Im just running the laptop on the high performance energy setting
Notes: The UE4 runs pretty bad on laptops, so when somebody want to develope a game with the UE4, he should buy a good PC

======= kassane =========
OS: Windows 7 x64 SP1;
Type: Desktop
Processor: Core i3-3210 Ivy Bridge @3.2Ghz;
Memory: 6GB RAM;
Graphics: Intel HD 2500;
Average fps: 7~15fps.
Settings: I disabled all Post-Processing in viewport’s Show->Post-Processing menu and Anti-aliasing.
Notes: In the beginning was very slow with low frames 3~7, but after disabling the anti-aliansing and all post-processing was better than before.

======= RyanGadz =========
OS: Windows 8 64Bit
Processor: Intel i7 6-core
Memory: 64GB
Graphics: FirePro 7900 : now Geforce 770
Average fps: Firepro 18fps : Geforce 33fps
Screen Resolution: 2560 x 1600
Settings: Default

Thinking of steping up the Geforce 770 to a Titan Black. I just read a thread that SLI does nothing (and that is what I was planning to do).

======= Infected =========
OS: Windows 8.1 64 bit
Processor: Intel Core i7-4930k
**Memory: **16Gb 1600Mhz
**Graphics: **EVGA GeForce GTX 770 Superclocked w/ ACX cooling (2-way SLI)
Average fps: 119.98 (120Hz Monitor) in regular editor, 20’s to high 60’s when in debug editor
Settings: No special changes.
Notes: More specs in signature link.

I have nearly identical setup that you have but getting much lower results so I looked up your monitors 1920x1200 yes? I changed mine to that res and my FPS went up to something similar as yours. Its worth mentioning that it also depends what scene we are using. I am “benchmarking” mine with the “ContentExamples: Effects.”

Yeap, all 3 monitors are 1920x1080. Only difference is my main screen being a 120Hz.

======= Sh!ft=========
OS: Windows 7
Processor: AMD FX-9590 4.7 GHz
Memory: AMD DDR3 1600 16GB
Graphics: ASUS R9 290x DCII OC
Average fps: Seen as low as 50 and as high as 120
Settings: Using the default settings.
Notes: Running on a Shimian 27" IPS 1440p monitor. Looks fantastic.

========Shadowriver==========
OS: Windows 7 x64 SP1;
Processor: Interl Q9300 Peryn @2.5Ghz;
Memory: 4GB RAM;
Graphics: GF9600GT 512MB;
Average fps: Around 20fps
Settings: Didn’t play with them yet :stuck_out_tongue: Disbaling Post Processing giving me few more fps
Notes: Runs good enoth for me to test my code (but not on perfermence side), average 20fps sometiems go down to 10fps, but mobile examples around 40-50fps, well they made for weaker mobile hardware… so they do better on weaker hardware :stuck_out_tongue:

======= Helghast =========
OS: Windows 7 Ultimate x64 SP1
Processor: Intel i7 4800MQ 2.7Ghz
Memory: 32GB RAM 1600
Graphics: GTX 780M 4GB
Average fps: between 90 - 100 fps
Settings: Default settings
Notes: If I do not limit frames to 30 or 60, GPU temperature exceeds 80ºC quickly.

======= bleeds187 =========
OS: OSX Mavericks
Processor: i7-4650U (1.7ghz dual core)
Memory: 8GB
Graphics: Intel HD 5000
Average fps: 25-30 with an empty scene
Settings: Default settings; Engine scalability makes almost no difference in framerate, only in quality
Notes: CPU usage is high and goes even higher with Realtime disabled (yes this makes no sense); the only way I was able to reduce CPU usage was by using “t.MaxFps 15” in the editor console

======= shadowcoder31 =========
OS: Windows 8.1 64bit
Processor: Intel i7-2600 @3.4 GHz
Memory: 6GB
Graphics: ASUS GTX 660 TI OC
Average fps: 60-100
Settings: Default (Epic)
Notes: On 1920x1200 monitor.

======= SonKim =========
OS: Windows 7 Pro 64-bit
Processor: Intel Core i7-3930K @ 3.2 GHz
Memory: 64 GB
Graphics: nVidia GTX 680 4GB
Average fps: 45 fps
Settings: Using the default “Epic” setting, no changes made.
Notes: fps can drop to 30 fps and stay as high as 60, on the example FPS shooter game I stay at a constant 60 fps at 2560 X 1600 resolution.

======= JKnife =========
OS: Windows 7 Pro 64-bit
Processor: Intel Core i7-2700K @ 3.5 GHz
Memory: 16 GB
Graphics: nVidia GTX 760
Average fps: 43 FPS Debug Editor build - 61 FPS Development Editor build
Settings:no changes made.
Notes: 1920x1080p using reflections map

======= mikepurvis =========
OS: Win 7 Pro 64-bit
Processor: AMD FX 8320 3.8 Ghz
Memory: 16 GB
Graphics: nVidia GTX 750 Ti
Average fps: 60 to 120 depending on map, 120 blank map
Settings: none
Notes: 1920x1080p x2 monitors

======= vBalbio =========
OS: Windows 7 64bit
Processor: Intel i5 2500K (3.30 GHz)
Memory: 8gb DDR3 1333
Graphics: PYN GTX560TI OC
Average fps:45~65
Settings: When “Realtime” is enabled i had a huge vga consumition even if Unreal Editor is minimized, i just turn it of and it’s all ok
Notes: none

So from reading the forums people have stated that with an nVidia Geforce 660M 2GB GDDR5 that they are getting an excess of 30fps with UE4 set to ‘Epic’.
My system spec, from what I can tell, is fairly decent and with what I’ve seen from others, I should be getting 30FPS.

System:
i7 3610QM 3GHz Quad Core
16GB Ram
nVidia Geforce 660M 2GB GDDR5
256gb SSD (primary) 1TB HDD (slave)

UE4 is installed on the SSD. I’m really curious to see if I can pull more frames out of this machine.
Some feedback would be greatful,

  • Sythen.