Coloured translucent shadows?

It is not possible in UE4 and that part of the documentation is from UDK(UE3) so i guess they havent updated it. UDK | Lightmass shadows

Hi All

Quick question I’ve been getting mixed responses on. Can UE4 render coloured translucent shadows based on the image they pass through? An example of what I mean is direct light through a stained glass window. I’ve read that the transmission material option was removed in UE4 as it was present in UDK, a feature which I used a lot for architectural renderings. However I found this article that says it should work. (about halfway down the page)

If it can work, how do I set my material to transmit this colour without having to use a light function on 3 spotlights with 3 textures for RGB? Decals will not work for what I’m trying to do either.

Thanks! I thought so, the documentation shows UE4 screenshots below the translucent shadows portion so I was confused.

Aha! I never noticed the section titles. I stand corrected. :slight_smile: Thanks Daniel!

It does work in UE4, but only from a light whose Mobility is set to Static. Stationary lights don’t support it and that’s the default light Mobility. Note that it’s under ‘Features for Static Lights Only’ in the UE4 Lightmass doc. The same was true for UE3 but the doc didn’t reflect it.

As Daniel pointed out it is possible. Here it is working in UE4 along with the setup for an unlit Stained Glass material.

I hope this helps!

Tim

Awesome! I’ll give that a shot. I do have 2 moving doors in the scene, so to light them i should just put a couple dynamic lights which only cast on them?

As a reminder, this effect can ONLY be achieved with static lighting. There may be a way to fake it with RGB light functions, but I’ve not tested that yet. And even if that is possibly it will only be Full Red, Green, or Blue for the color values.

24846-2014-12-23_nocoloredshadows.png

Hi, I’ve tried to get the colored shadow, but I keep getting a grayscale shadow. There might be some very faint traces of pink in the shadow but not as strong as suggested. The left material on the image is actualy a lit transparent material. But according to CPU Lightmass Global Illumination | Unreal Engine Documentation
it should take the basecolor linearly interpolated with white by alpha, but no luck. Has anyone gotten this to work properly?

@isgoed:

Can you post an image of your material setup, please? I can take a look and see what’s going on.

It may be that you do not want to use the setup that is listed above as Translucent or Additive may work better for your needs.

I’ve used these methods a lot in the past and I wrote the tutorial that you’re referenced in your post on the Forums.

Let me know and I’ll see what I can add to help you get it working. :slight_smile:

Tim

Hi Tim,

See the screenshot attached:

@isgoed:

Here is a screen shot of my setup using your material.

It may be a little difficult to see, but if you open the image in a new tab you’ll see it at full resolution and you can see their is color transmission.

One thing to make sure in your scene though is that you are using ONLY STATIC LIGHTING. Transmission will not work with Stationary or Movable.

Thank you!

Tim

Ok thanks for you effort.

I did some more tests and got it working.
I got the following results

  1. Blend mode modulate: Works (see right amethyste material in added screenshot), but modulate does not support a lighted shading mode. Please REALY REALY fix this! In fact in my post Translucency and Reflections finally working in UE4.6, but still so many problems... - Feedback for Unreal Engine team - Unreal Engine Forums

I have the “pinky material” which does its own modulate calculation in translucent mode and this works perfectly! So there is no technical reason why this should not be possible.
2. Blend mode additive: Works (See left amethyste material in
added screenshot).
3. Blend mode translucent: Very poor. You hardly see any colored shadows regardless wether you set opacity to low or high. Still seems there is something wrong with it.EDIT: CORRECTION: seems it works though. I had two light sources at the same position. One stationary and one static. I needed the stationary, because without it the tricked reflection effect did not work (was just static. this is still a bug in my opinion). Setting the stationary lights to 1/100th of its intensity showed the effect as on the left material of screenshot 2. I could exaggerate the effect by multiplying the base color by 10. that’s what you see in the right material of screenshot 2.