Download

Color banding in editor window compared to texture preview

As the title says I am having issues with
I am using an unlit surface shader with a substance generated texture

I have not used UE4 in years so I will put a list of what I have tried thus far to resolve the issue.

1.Changed mip maps to none
2.changed compresion settings
3.Changed all relevent shader settings (and none-relevent too just incase)
4.changed the viewport to unlit.
5.turned off all post processing in the editor view

Here is a screenshot of the difference

19469abbb56fc8cbaa2eb8ae132b61adefff04d3.jpeg
https://forums.unrealengine.com/core/image/gif;base64
​Notice around the edge as you get to the black areas on the left side that the color bands much more than the one on the right

Gotta say, I can’t see a lot of difference. Do you get the problem in play mode?

Have you turned off auto exposure?

Thanks for the suggestion, interestingly in play mode it looks a lot better, again different from botht he editor window and the texture window, but the banding isnt there (or at least with the settings I used)
The difference isnt too easy to see in the forum post preview, its more noticable if you open it in a new tab, even more noticable when I actually scroll in closer in the editor

Thanks for the help though much apreciated!