Collison Radius is not where the Spawned Object is (Procedural Foliage)

I made a Landscape with many hills, and wanted to create a simple forrest. I createt two very similar types of trees and a bunch of grass. I generatet the forrest with the Procedural Foliage Spawner. On flat Ground it all worked perfect (no clipping grass), but on the side of hills the grass was clipping into the trees. Also directly next to the tree DOWN the hill, there was a round patch of landscape with no grass on it.
I tried this with some test meshes (some cilynders witch diferent originpoints) and played with some settings, but nothing helped.
Here are some pictures that show the problem:

On flat Ground:

On the side of a hill:

Hello Bassline,

Within your ‘Procedural Foliage Type’ asset in the ‘Content Browser’ be sure the ‘Collision with World’ is enabled for the cylinder objects.

Could you provide me with some screenshots of your procedural foliage type settings, so I can get an idea of the options you have selected for each foliage type?

Thank you,

Check the ‘Collision with World’ option to see if that resolves your issue.

When ever I Check the Collision with World option, It spawns significantly less foliage. I have to Increase the Seed Density and Steps to the Point where my Computer (i7-6700, 8Gb RAM) struggles. It is also a very tiny area.
On top of that, it also seems to not resolve the problem. The empty patch of land is still beside the “treetrunk”.
I keep trying to solve the problem myself and hope that there is an easy solution.

Thank you for your help so far.

Could you provide me with a test project so I can verify what you are reporting. In all honesty, it sounds like it is just a settings issue, and you need to get the correct values to account for the changes in height and collision.

While you are messing around with the settings, I would take a look at the Procedural Foliage Spawner: Tutorial to help familiarize yourself with the feature and settings a bit more, just in case you need some more insight.


Thank you very much. To be honest it is verry possible that the mistake is on my side. I’ll try to figure it out and post the answer to this problem here, so poeple like me can see there mistake.

Cheers, Bässline.

Here is a link to a Testproject. I hobe this helps.

Yeah, keep playing around with the settings and if you cannot get the results you are looking for, there is always the hand painted method. I used this route with your example project, and was able to paint a dense amount of foliage no matter the angle of the ground.

And were you able to get it working correctly with the trunks? So that it doesn’t look displaced like in the pictures above?

Yes, I had no problems getting the trunks to embed into the ground as expected.

I actualy mean the coreproblem I describe at the very top. With the grass not being where it should be.

Yeah, I was able to hand paint depending on the settings applied within the foliage mode, and the grass appeared as expected.

Ok thanks, but my map has roughly 2.5km² of forrest. So… not realy an option. :smiley:

It must be a collection of the settings you are using within the Foliage Type which are restricting it from appearing it as you expect. Keep experimenting with the settings, and if you cannot get it to appear at all let me know and I will continue to help you find the correct resolution.