Collision problem with my static meshes

Setting Collision enabled to “physics only” allows the player to walk through, setting it to “query only” blocks the player from passing through. How is this not backwards? How do I fix this?

Hi! Check out that ECollisionEnabled::Type | Unreal Engine Documentation

  • QueryOnly is used to calculate overlaps, hits, raycasts
  • PhysicsOnly is used only to calculate Physics, but Physics pays attention to RigidBodies that are created for Components and not Colliders

This groups are formed to separate objects that are participating in Unreal physics engine from those who are not.

Theoretically you’re right, but practically my overlaps never work if I set collision to Query Only, but work with QueryAndPhysics. So there is something wrong with this.

Double check if the two actors are set to overlap with the collision type of the respective other (you did not inlcude a screen of your collision settings). I believe for an overlap it is enough, for only one of them to set to “overlap” the other.

Having said that, setting to query only should in theory never result in blocking… Since you are changing the collision settings at runtime, are you sure you are not setting it somewhere else in your code as well?

Default reactions can be configured here. Depending on that you can get blocking hit or overlap or nothing alt text