Download

CodeLite Source Code Access and Project File Generator for Unreal Engine 4

where i can find this plugin?

It is installed already.

Hi @yaakuro. I created this page for windows usage.

Sadly for me it didn’t worked (windows) :frowning:

I have the exact same “intelisense” in codelite that I have in visual studio '17, that’s NONE. It doesn’t matter what I type, the editor never pops any “solution” at all. So this is total old school trying to read documentation and finding the proper parameters :confused:

Hi fellows

New update. I added new feature (Virtual Folder for Project in Workspaces) that is available in CodeLite 10.0.3+ I asked long time ago the main developer to support that feature and he implemented it quite fast. Thx a lot for that. With that I could rewrite the UBT CodeLite Project Generator a bit to support that feature to organize UE4 projects better in the Workspace. In the following picture you can see how it looks like. I will soon make a PR for this.

Ok, long time no see. For those (not sure if any) who is using CodeLite with UE4, I made a new PR for 4.20 that fixes issues with opening the workspace file.

https://github.com/EpicGames/UnrealEngine/pull/4992

You can get it from my repo too:

checkout the 4.20 branch.

Yaakuro, I have both Unreal Engine and CodeLite installed on Ubuntu 18.04 with KDE plasma. The *.workspace file opens in codelite fine.

The wiki here (https://wiki.unrealengine.com/index…Code_Accessors) says to edit the LinuxEngine.ini file and change it from NullSourceCodeAccessor to CodeLiteSourceCodeAccessor however doing that will cause errors and new projects no longer build, here is a similar/related post: https://github.com/dotBunny/CLionSou…cess/issues/96

so it seems the wiki that suggest editing the **LinuxEngine.ini **file is outdated, and that step should NOT be done.

So for the most part things work, but the plugin that is already installed on linux Unreal Engine that is to allow you to open your c++ class files in codelite when double clicked from within Unreal Engine, does not seem to be working.

How do I get that to work? for example your video here at 6:49: CodeLite as primary IDE for UE4 on Linux - YouTube you are able to open your c++ class files directly from Unreal Editor.

EDIT: OK somehow I missed your Note on your github page: GitHub - yaakuro/CodeLiteSourceCodeAccess: CodeLite Source Code Accesor for the Unreal Engine 4</title

It says that the CodeLite plugin currently included with Unreal Engine no longer works in Unreal Editor 4.18+ and that I should instead clone from your github page.

I wish the Unreal team would look at your pull requests sooner, would have been nice if the included plugin would have been up to date. I was scratching my head wondering why it would not work, thinking I must have done something wrong.

THANK YOU for making this plugin as well as the youtube videos showing how to use codelite with Unreal Engine on Linux. I really appreciate it.

Hi Tielix,

sorry for the late reply. This short description is for everyone interested in using CodeLite on Linux.

  1. Tthe current version which comes with UE4 does not work anymore: 18+ >. I told Epic about that issue long time ago but unfortunately they seem not to care for now. That shouldn’t stop you from using the version I am providing. I just recently made an update to the 4.23 branch (actually nothing changed so far). You that in your UE4 local copy instead of the version that comes with it.

  2. After updating your CodeLiteSourceCodeAccessor (which is located inside: Engine/Plugins/Developer/CodeLiteSourceCodeAccess) just open your project inside the UE4 Editor. Go the the Editor settings and select the “Source Code” submenu, in there you will see the Accessor field. Select “CodeLite 10/11/12”. See picture below.

  1. No need for now to modify the **LinuxEngine.ini **file.

Hi; have a problem with detecting the platform, the newest codelite version is installed but on UE4.26, is there a problem with the new engine version do i have a older version?
Try different ways to find the platform but nothung helps, what im doing wrong?here is a picture: Detecting_Fail.PNG