Download

CodeLite Source Code Access and Project File Generator for Unreal Engine 4

Hi Yaakuro

I have realized something that needs to be taken care of.

First, the problem is, if the editor is not running, building the project fails. I compared CodeLite with VS to see the difference. After making some research i realized that:

While Editor is not running, if build is started, this output is given:

My first guess was something regarding Unreal was wrong. Because when editor running, it wasn’t the case and building was done properly. However i made a comparison with VS and CodeLite and found this.

VS calls build.bat and adds -rocket to command. I made a comparison between all build and clean commands. Here is an example:

As you can guess all rebuild does is calling clean first then build.

Here is the output of new build command:

I am going to check if those params are needed inside linux. However i doubt it, since you have been using it inside linux for a long time. Also i have no idea what the situation is inside OSX.

**EDIT: **For short -rocket and -DEPLOY for build and -rocket for clean is needed inside Windows.

**EDIT2: **I have tested those inside Linux, and found that those parameters are invalid inside Linux. Don’t know OSX but probably they are Windows only.

Well I tested with and without it works. What is the deploy flag? Maybe the rocket build is only for those ue4 used from Binaries not the one compiled from source source.

I have asked it at answerhub. But couldn’t get and exact answer.

Only thing i learned is -rocket means it is being compiled from editor. Therefore not deleting hotreload files(which would crash the engine). However i don’t think thats exactly the truth since VS also uses -rocket. I just don’t know :frowning:

-rocket means it compile like launcher version, it won’t compile toghther engine souce files only your project modules and project plugins, meaning you can rebuild without worring that your engine bineries will be killed.

Hello friends and fellows

Here a video how to use macros to highlight code in CodeLite. YouTube.

Switch to CodeLite version 9

What’s your codelite version and your theme and how do you build and run the project? Mine crash, i believe this.

Can you give more information? What is crashing? CodeLite? UE4Editor?

@Yaakuro, I am having issues with CodeLite too. I went to plugins in the editor but did not see CodeLite as an option. Do I need to do something before I can see an option to use CodeLite as my IDE? I rather use QT or a built-in code editor. I have been having so much trouble trying to setup Unreal so I can use C++ though that I was ready to try anything just to get a working C++ Unreal environment setup.

I was able to download the zip of 4.10 and now I see the codelite plugin. Its checked now. Unfortunately, I still cannot get anything to run though CodeLite. I don’t have any issues building the project. I built it in CodeLite and got an executable. I just seem to have some kind of strange runtime error. It crashes saying that it caught a SIG11 and reports that there was a problem accessing a memory address.

I think we solved your problem on youtube right :smiley:

Yaakuro, amazing work! This seems to be working well, Thanks! :smiley:

where i can find this plugin?

It is installed already.

Hi @yaakuro. I created this page for windows usage.

Sadly for me it didn’t worked (windows) :frowning:

I have the exact same “intelisense” in codelite that I have in visual studio '17, that’s NONE. It doesn’t matter what I type, the editor never pops any “solution” at all. So this is total old school trying to read documentation and finding the proper parameters :confused:

Hi fellows

New update. I added new feature (Virtual Folder for Project in Workspaces) that is available in CodeLite 10.0.3+ I asked long time ago the main developer to support that feature and he implemented it quite fast. Thx a lot for that. With that I could rewrite the UBT CodeLite Project Generator a bit to support that feature to organize UE4 projects better in the Workspace. In the following picture you can see how it looks like. I will soon make a PR for this.

Ok, long time no see. For those (not sure if any) who is using CodeLite with UE4, I made a new PR for 4.20 that fixes issues with opening the workspace file.

https://github.com/EpicGames/UnrealEngine/pull/4992

You can get it from my repo too:

checkout the 4.20 branch.

Yaakuro, I have both Unreal Engine and CodeLite installed on Ubuntu 18.04 with KDE plasma. The *.workspace file opens in codelite fine.

The wiki here (https://wiki.unrealengine.com/index…Code_Accessors) says to edit the LinuxEngine.ini file and change it from NullSourceCodeAccessor to CodeLiteSourceCodeAccessor however doing that will cause errors and new projects no longer build, here is a similar/related post: https://github.com/dotBunny/CLionSou…cess/issues/96

so it seems the wiki that suggest editing the **LinuxEngine.ini **file is outdated, and that step should NOT be done.

So for the most part things work, but the plugin that is already installed on linux Unreal Engine that is to allow you to open your c++ class files in codelite when double clicked from within Unreal Engine, does not seem to be working.

How do I get that to work? for example your video here at 6:49: CodeLite as primary IDE for UE4 on Linux - YouTube you are able to open your c++ class files directly from Unreal Editor.

EDIT: OK somehow I missed your Note on your github page: GitHub - yaakuro/CodeLiteSourceCodeAccess: CodeLite Source Code Accesor for the Unreal Engine 4</title

It says that the CodeLite plugin currently included with Unreal Engine no longer works in Unreal Editor 4.18+ and that I should instead clone from your github page.

I wish the Unreal team would look at your pull requests sooner, would have been nice if the included plugin would have been up to date. I was scratching my head wondering why it would not work, thinking I must have done something wrong.

THANK YOU for making this plugin as well as the youtube videos showing how to use codelite with Unreal Engine on Linux. I really appreciate it.

Hi Tielix,

sorry for the late reply. This short description is for everyone interested in using CodeLite on Linux.

  1. Tthe current version which comes with UE4 does not work anymore: 18+ >. I told Epic about that issue long time ago but unfortunately they seem not to care for now. That shouldn’t stop you from using the version I am providing. I just recently made an update to the 4.23 branch (actually nothing changed so far). You that in your UE4 local copy instead of the version that comes with it.

  2. After updating your CodeLiteSourceCodeAccessor (which is located inside: Engine/Plugins/Developer/CodeLiteSourceCodeAccess) just open your project inside the UE4 Editor. Go the the Editor settings and select the “Source Code” submenu, in there you will see the Accessor field. Select “CodeLite 10/11/12”. See picture below.

  1. No need for now to modify the **LinuxEngine.ini **file.

Hi; have a problem with detecting the platform, the newest codelite version is installed but on UE4.26, is there a problem with the new engine version do i have a older version?
Try different ways to find the platform but nothung helps, what im doing wrong?here is a picture: Detecting_Fail.PNG