Code changes are not reflected in editor upon rebuild

How did you build the project?

Steps to reproduce:

Create a C++ Rolling Template project

Add a breakpoint to the Ball’s constructor

Build the project, then play in editor

The breakpoint will not be hit. The breakpoint’s tooltip will say “The breakpoint will not currently be hit. A copy of ball.cpp was found in UE4Editor-Test.dll, but the current source code is different from the version built into UE4Editor-Test.dll.”

Development Editor Win64 build configuration. I set Test as the startup project, then hit F5 to build and start with debugging.

I have tried right-clicking the project to build it already. Also tried a right-click rebuild.

I just hit F7. The tooltip hasn’t changed.

Ever since I wasted a chunk of time wondering why my changes had no effect, only to find that VS hadn’t actually built my changes, I’ve been very suspicious of ever using F5 to build (admittedly that wasn’t on UE4).

Could you try either right-clicking on your project and building from there (which is an option UnrealVS has built in - I usually bind it to Ctrl+Alt+Shift+B), or just press F7 to make sure everything is built.