Clothing Tool Collision not working!

I am not sure if this will help you, but I managed to get it working in an isolated test project using UE17.1 preview.
In that version you can explicitly specify a physics asset to be used for cloth collision. That did the trick for me.

Another possible cause I stumbled upon is a wrongly scaled physics asset. Apparently, the FBX importer can mess up the scale of physics assets when importing them. Even though the assets looks fine, it might be tiny when used for cloth collision. However, this is probably unlikely in you case since it also happens with the Epic character model.

I did follow every method in Documentation,It work but the collision is not working. Any solution?

Need help!!! : (

So where can I check any Collision Parameters set?

Thank you for reply my question.

I tried to use model from Epic games but collision still didnt work either.

I have the same problem. I tried do document my setup here:
I checked the Physics Asset, Ragdoll physics seem to work just fine.

I still can’t find a way to solve this.
If you found a solution please tell me.

same problem on 4.17, i’ve tried to recreate the physic asset, modify the cloth on blender and play around with parameters, but nothing seems to work, cloth get through the mesh

I’m still can’t solve this issue even i upgrade to 4.17.

Hi CrossToJoy,
Did you solve this issue? I have the same on 4.17. Even with possibility to change physics assets. Also I found out that some bodies are colliding with cloth, but some not. And it’s very easy to lose this state - I had one phys body colliding with cloth, but after adding one more phys body to other bone, the previous one is not colliding anymore. This is very strange and unstable behavior.

Hi mate. Could you please let us know how do you check physical assets scale? I’m using my own skeleton and I see some physical bodies colliding with cloth but some not (even dublicated). But in debug view all collisions looks fine.

i am using 4.17, same problem. And i tried doing this to mesh too. I don’t know what i am doing wrong

Solution for a problem with collisions:

I am here to rescue you if you are still having this issue! I had exactly the same problem and i was able to solve it.


First of all, look at your first screenshot. On the upper left of the preview window it says - Approx scale: 438x578x2831. This 2831 is a problem. If i am correct it should only appear when you add cloth to your mesh. Please check the scale before and after you add the cloth.

If the scale before is different, then it is causing an issue and here is what is happening:
Assuming that for the original model you are using Blender, the problem is with export. You could be exporting a resized model because the original is too small/too big. When you assign collision shapes to the bones of such model in Unreal it maps their actual position in relation to your models original size. So as a result you will see no collision at all if the collision shapes are messed up too much (like in your case where z axis goes all the way to 2831).

Here is what solved my issue:
Go back to Blender, select your entire rig in object mode and press Alt + S. If the scale changes - good. It is a sign that your problem is because of the scale of your model. Now make sure that whenever you export your model from Blender its scale on every axes is always set to 1. You can check your scale in Blender in object mode in the object window at the properties panel.
You need to make sure you are exporting your fbx at scale 1 and then also when you are importing to Unreal, make sure its always scale 1. Also you should probably reimport the animations (if you have any) if they get messed up in Unreal.
If your model is now too big\too small after importing to Unreal, the collisions will probably not work but you can try. It needs to be somewhat around 200x 200 x 200. If its somethig like 8x10x 7 it wont work, and if its too big (2000x2000x2000) it wont work either. It needs to be more or less of the size of the character.
If the size is too big/too small and collisions are not working go back to Blender and change the size of a rig and then press Ctrl+A and apply Rotation, Location and Scale in this order. Export again with the scale of 1. Also you might make sure that your scale is set to Metric.
Now resizing the rig can mess up your animations. Unfortunately in my case I had to remake them. If you have a better way of doing this - please let me know.
After this just add collision bodies and cloth in Unreal like you normally do and see if the size of your model chages again. If it doesnt, gratz, the collisions are probably working, and if not, here is another step you can do (i had to do this to make it work)


Why collisions didnt work either or problem number 2.
You can apply this in any order and in fact your collisions might work right away after this step.
Cloth only responds when you have a very few number of collision shapes attached to it. has many. Create an additional physics asset for him just for cloth, delete all of the collision shapes and create a couple of your own at hte bones you want your cloth to collide with. 4 or 5 worked for me. I think it cant’t handle more than 8 or 16.
Make sure the collision shapes are capsules and not Boxes. If you have at least one box the collisions wont work.
Also if you modify physics asset after adding the cloth, the cloth will break. You will have to remake cloth asset if you modify physics asset. For now there doesnt seem to be a workaround but since the feature is experimental its not that bad as long as it works…


Just a small thing you can do as well is to try and export the model from unreal back to 3d program and then export from it again. This might solve the problem on its own but it didn’t work for me.
Also you might notice in your 3d program that Unreal creates an additional object to which your model is parented to. Deleting this object will rescale your rig if its been of a wrong size on original export.

Sorry for a long text but i felt like explaining the problem in detail because there are many people out there struggling with it and i havent been able to find any single answer.

You saved my life thank you!
It was the Clothing assets that broke everytime i modified the physics assets sphyril shapes.
I guess you can just remove the clothing assets before modifiying the physics asset collision shape and then re apply to not break it!

Creating a separate physics asset with fewer bodies solved this issue for me.

None of this helped me.

what exactly was your issue?

link text

I’ve got consistent scaling when applying the cloth, and only testing with 2 capsules. Still not getting any collisions? Anyone have any ideas?

No, i dont know what epic did to cloth but its not working since 4.17

Thank you! I’ve finally solved it! I use your III method i export form Unreal and import again.

Thank again! You help me a lot.