Clever real-time posing with Mo-COntrollers but FINGER MOVES like a GHOST is haunting them!

I have been using the Physics Simulation mode of Unreals VR Editor (and the fact you can save the physics pose) just by pushing and pulling on the mannequin. It all works great until I try to get the fingers in on the action! I can see what I am forgetting! I give themphysics constraints, I turn off gravity I turn the linear and angular damping up to 5000. it works great with everything except the fingers, Am I missing collision boxes on ther standard Mannequin fingers? I thought Constrainsts would be enough,. ANY HELP very welcome! PLEASE !!
I have images of the settings etc and a short video to show what is happening, Make sure the volume is not too loud! :slight_smile:
video:(Unlisted video) Trouble keeping unreal fingers still! - YouTube
My good ARM settings, my similiar but Insane and Haunted Finger settings below ??


Never mind! I figured it out, I had to make nice tight ‘single convex hulls’ for the fingers so the constraints would be based on those and not interfere with each other! (in the Physics Asset edit window, select finger bones, in the ‘Tools’ panel, ‘Body Creation’ Drop down choose ‘Single convex Hull’ and click ‘Add Bodies’, it will create collision and constraints then in the Details panel, you just select limited (or locked) for Angular Limit, locking the Twist and appropriate angle for fingers and thumb! and increase the Linear and Angular Damping to a high number like 5000. I like to turn ‘parent dominates’ on (checked after selecting a constraint) so the finger can be moved without changing your arm or hand pose!