Classes not showing up in content browser

I can’t get any classes to show up in the content browser, and I can’t seem to make new ones. I’ve restarted the whole project 15 times, each time with a different name, using different settings for the initial setup (with and without starter content, as blank, top down, third person, 2d side scroller, etc). I’ve tried copying code, copying the files, dragging the files into unreal, creating new files to start completely from scratch (as None, Character, Pawn, Actor, Actor Component, and every other possible class file) and not a single one of them will show up in the content browser, and only the first file will ever actually be made and open in visual studio. I have also uninstalled and reinstalled both visual studio and unreal engine. Any additional files I try to create I get this:

Successfully added class ‘MyClass’, however you must recompile the ‘MyProject’ module before it will appear in the Content Browser. Failed to automatically compile the ‘MyProject’ module.

Does not matter what I do. I don’t get this message on the first class I try to make, only the ones after it, but the first one still does not show up and cannot be used.

If you go to the Output Log, it will show you more information about why the module failed to compile. Please include that.

Tried to get it to replicate. Now I can create any number of classes and its not giving me any kind of errors or any log at all, and its still not showing anything in the content browser.

Try to:
start your VS project without UE, then run debug with development editor( on the right side of the “Run” button). It will start UE and your classes must be visible now

1 Like