Class "USceneComponent" has no member "AddForce" or "AddImpulse" And "GetMass"

in cpp

 void ANewActor_::BluprntFunction() {
    	Mesh_->AddForce((FVector::UpVector * 1000) * Mesh_->GetMass());
    	//Mesh_->AddImpulse(FVector(0, 0, 1000) * Mesh_->GetMass());

in .h

	// Called every frame
	virtual void Tick(float DeltaTime) override;

		void BluprntFunction();

Don’t understand what the problem is? USceneComponent doesn’t have them, so …

You might want to use the UPrimitiveComponent, which derives from USceneComponent.

Unless, of course, you’re trying to set those members for the Mesh_ component. If that’s the case, then the error, is probably related with the lack of the proper header.

If static mesh:

#include "Components/StaticMeshComponent.h" 

If skeletal mesh:

#include "Components/SkeletalMeshComponent.h"

What is up with the bad naming? ANewActor_ ? Mesh_ ? I have never seen any coding style do that and it looks disgusting. That _ is a useless and ■■■■ ugly extra char.