Circle of shadow follows player-shadows off tho

wth is going on now ;),shadows have been following my character as he goes fwd, I was told disable shadows on directional light which was working, but now using sun & sky with expo heightfog, which one of those if not directional light maybe causing that ? 4.24.3

I’ve gotten rid of every instance of shadow I can find in settings, project settings etal, so not sure where else to look. Disabling shadows used to fix this.
Happy overall w/lighting finally but this traveling shadow spoils the fun :wink:;base64

1 Like

I think what you are calling shadows is actually not a shadow at all but a huge circle?
if so, it’s the height fog.
it works sort of like a huge sphere around the player (or camera).

If that’s the case, you can lessen the effect by messing around with the height fog settings.

If that’s not it, try having a look at the different render passes to determine where the shadow comes in within the render pipeline…

It’s as circle I guess, hard to tell to see it in iits entirety and its different in some areas where the light is stronger, but not just a ‘circle’ of sorts, it does as a shadow would it takes on the shape of things behind it, so I’ve no clue what it is ;0-0

I messed with everything, nothing changes, sure I can more or less wipe it out but that mandates pushing the fog so high that everything is overwhelmed with saturation, so thats not a go either.

What do you mean , to see where render pass comes in within the render pipeline ?

Not volumetric.


Disabled (and moved outside the post process, which is why it’s not blue)

… buffer visualization example:

Check the rest of the channels that aren’t displayed by default to see if you can find where it is being generated…

Also, note that if this is the exponential height fog, the circle is created by the “start distance”. that’s distance from camera.
That’s not related to height fall off or fog density.

Seems to be, tho lighting is complex, hours into it ( many others too I see ) the SkySky ( Sun & Sky component), as if I untick it, all that cruft goes away , but without it ofc the scene is blahs ville.
Is that expected behavior ,if I choose various times of the year it goes away basically, is this a bug I wonder, or something 4.25 will fix maybe dunno.

It just ruins realism and makes it hard to work and continue the process of creating…for me anyway, I need consistency like everyone else I guess.

Lighting , what a mess.
Anyway at least that ‘seems’ what it is as above,also if I increase intensity of Skylight, it goes away, but then oversaturation occurs so its meaningless as a fix.

The ever growing need for adancement of our game dev knowledge ;0-0

This, you can see shadow, softer, lighter now but its there, and as player, as noted, moves forward its annoyingly there .

I’ll keep looking but so far only way to get ‘rid’ of it, is remove Sun & sky, but ofc thats impossible, without I have no lighting worth mentioning.
I turned off shadows, because , maybe while NOT using sun & sky, that worked, but not using sun &sky I get horrible lighting results so I went back to this, again. :wink:

1 Like

did u ever fix this. unreal is ■■■■