Download

Cinematic Depth of Field resolution dependent?

Is it intended?
The cinematic DoF looks completely different if you see a shot in window mode or fullscreen.

Window

Fullscreen

As you can see, simply put a cinematic camera in a level and switch from window to fullscreen.

How can I set correctly a camera for a scene if it changes based on the resolution?

Very sad about this,
Alessio

No one has this same problem?
Seriously?

And, as you can see there’s no match with the “Draw debug focus plane”

I don’t think this is correct

Make sure r.taa.upsampling is set to 0. Temporal AA upsampling gets applied after the cinematic depth of field, lessening the blur. It also causes the image to look different depending on resolution.

Thank you for the answer, unfortunately the taa upsampling is set to 0.

r.TemporalAA.Upsampling = “0” LastSetBy: Constructor

Are there any other settings that can influence the DoF?

If you have this problem too, check your engine scalability settings and put them to Epic quality.

Is there a real fix for this? It’s wild. I’m on 4.23.

Yeah it is

Did you find a solution?

^ This is the solution

Did anyone find a solution to this?.. Having it on 4.25.3, scalability on, cinematic mode on… DOF in viewport is in focus, in the rendered image completely out of focus… Anyone figure this out??

I am experiencing this issue as well…cant seem to figure it out. Are you using the Movie Render Pipeline to render out?

Did anyone find the solution?

For me I was having the same issue as giomagneto and solved it by going to Settings > Scalability > Engine Scalability Settings > Set to Cinematic

Exact same problem for me in 4.26. My scalability has been always set to Cinematic so that’s not the source of the issue. I’m rendering with the Movie Render Queue.

Were you ever able to solve this? r.TemporalAA.Upsampling 0 didn’t get rid of my weird DoF.