Download

Cinema 4D Workflow

About C4D and Character Animation Workflow

Unfortunately Maxon has not made those EXELENTS Character Builder (C4D Modular Rig System), and CMotion (Procedural Animation System), both compatible with Game Engines.

First all, the Rig created contains more than one root (is a multi-root skeleton), making the skeleton incompatible with Unreal Engine.

It is impossible to import in Unreal Engine or change this skeleton in C4D. It has hundreds of constraints and complex xpresso tags for driving CMotion animations and IK solvers very different from the commonly used.

Baked animations can be imported perfectly. But without a skeleton are completely useless in Unreal Engine.

[FONT=Arial Black]I had to practically recreate the entire rig and animation in Maya again.:frowning:

More than a week of work thrown away, just because I did not know that the Unreal does not accept multi-root skeleton, and besides all without a main-root in 0,0,0.
[FONT=Arial Black]
But is this proposal! If anyone here has contact with Maxom. Please ask them to make CMOTION and Character Builder compatible with Game Engines like Unreal or Unity. Or tell me if there is a practical solution to this

Was wonderful when I managed to do this in C4D in less than one minute without touching any joint or controller. But…

PS .: Animation created in C4D does not work in sketchfab also .

[FONT=Arial Black]luny

You can import a Character made with Cinemas Character tools if you do a few minor alternations to it’s hierarchy to get rid of the multi-root issue.

Ofc. you’ll need to convert the Character Object to an editable Object and rearrange a few things.

For this Example i used the female_clothed character found in the content browser (presets>studio>3D Objects>humans)

First of all i created a CMotion by adding a walking animation in the Character Object, because after converting the Character Object it’s not as easy to set up.
Next i converted the Character Object, converted the bind_null to a null joint and started rearranging the Subobjects.
I ended up with the hierarchy you can see below.

On import to UE4 i had to do a Rotation of Roll 90° for the animation to prevent the model doing it’s animations lying on the back.
But beside of that it transfered just fine.
720458d7ecb733b69f2b99be95b2217c6d825929.jpeg

Hi there,

has anyone by chance managed to export PoseMorphs/Blendshapes from Cinema 4D (R14) to UE4 (4.11)?

I’m using a FUSE-Mesh with some blendshapes which needs some tweaking inside Cinema 4D. The PoseMorphs are there and working within Cinema 4D. I tried like every FBX export option inside C4D. The supported FBX-Versions are 7.2, 7.1 and 6.1.
Maybe they have to be baked inside Cinema 4D or something, or do I need a newer FBX-Version?

The Mesh itself, bone structure and animations work perfectly when exported from Cinema 4D to UE4.

When I import the FUSE-Mesh directly they are also properly imported to UE4.

Thanks in advance.

Hi everyone,

My name is Alexandre. I am an architect and I just begin to explore the realtime archviz with UE4. . My workflow is Archicad / Cinema 4D / UE4. I followed JayCox instructions to UVW maps and export/import to unreal but I had some scaling / deformation problems with textures in almost all my UVW meshes. I passed throw all the process a second time to see if I made an error but i didn’t find anything wrong. I took some screenshot of my workflow that i would like to share with you. Maybe someone with more experience can find the problem.

An interesting fact is when I export/import my project directly from archicad to UE4 without making any change in cinema 4D and asking to UE4 to generate lightmap UV, I don’t get this problem, but I read in others topics that it may generate some futur problems with lightmap.

I am new to this forums… I hope I am posting in the right place… I am sorry if I am wrong.

thanks in advance!

Alex of Entrestudio

some example of UVW creation

As for the first warning about the smoothing groups, there’s nothing that can be done (beside using cactus dans fbx exporter),
but you can just ignore it, since smoothing will still import unless there are other issues.
I also noticed some of your meshes do not have a phong tag and because of this no smoothing at all.

The face material inconsistency is usually caused by a wrong tag setup. Try to have the material tags of all objects on the very left of the stack.
If you get a face material inconsistency for a mesh, it won’t import your material selections and instead create a default material and assign it to the whole mesh.

Also use “import normals and tangents” on import settings, but make sure all of your meshes have a phong tag prior to export.

When looking at your auto-generated UV maps, i can tell you that you will run into many issues with them.
Not only that they will make it neccessary to use a much bigger lightmap texture scale because of the bad UV space usage,
they are also split on surfaces that belong together, possibly causing visible lighting seems across these surfaces.

I was going to post some examples for a better understanding of how to get your scene from C4D to UE4, but it looks like they are allready in the same thread just on page #1:

Make sure to take a look at the example with the source files included.

A few more general hints:

  • try to combine meshes in C4D that make sense to be combined
    e.g. you might want to have a cupboard as a single object rather then split into two or more, but you certainly don’t want it to be combined with a wall.
  • try to avoid importing whole scenes including all props at once. Rather place stuff like chairs cupboards etc. in Unreal especially if there is more then one instance of them.
  • Ideally you place their pivot of these props in a good spot that makes it easy to place the prop in UE4.
    e.g. something that is meant to be placed on a floor should have it’s pivot at it’s bottom, while a wallight might be better off with a pivot at it’s back.
  • make sure to know how a lightmap UV and also a Material UV should look like, auto-unwrap won’t give you the best results in most cases.
  • same for Collision Meshes, in most cases auto generated collision will be inferior to hand crafted collision in terms of ammount of shapes used for collision and therefor performance.
    If you only need simple box collision or a single convex shape for a model use UE’s Mesh Editor to create it, if you need several pieces, rather build them with UCX_ meshes in the 3d App.
  • if your scene is lit by sunlight from outside, make sure that the walls and models have a backside even if they are not visible from the “players” view.
    Ofc. you should scale down the lightmap UVs for these faces to a minimum to save preciouse UV space.

Thank you for the tips kraid!

I will put this in practice.

The reason why I didn’t put phong tag in every meshes was to avoid some smooth corner issues. I mean, some sharped corner wasn’t sharp anymore. but, I definitely missed the “import normals and tangents”. Anyway, I will try again with phong tag in all meshes.

There is only one thing that I am not sure if I understood you… when you say:* “The face material inconsistency is usually caused by a wrong tag setup. Try to have the material tags of all objects on the very left of the stack”

  • I am scare that I will need more explanation about how to resolve and achieve this because I think this is my main problem.

I want to specify that my knowledge in cinema 4D is somehow limited. I always use archicad as my modelling software and cinema 4D for props (objects, trees and landscapes) and rendering process… all my textures and materials came from Archicad with cinerender (cinema 4D renders inside Archicad) and this workflow was very good (for static archviz obviously). So before working with UE4, cinema 4D was my “ending” software.

thank you again! :wink:

On the phong Tag you can change the angle limit. The shading will be smoothed across faces that have an angle smaller then this value and if the angle is bigger then the set value it’ll create a hard edge. (so for a simple cube everything up to 89° will result in hard edges)

Additionally you can always select some edges (in edge mode), right click and select “break phong shading” from the context menue.
Now if the checkbox “evaluate broken edges” is checked, these edges will stay sharp no matter what phong angle is used.

As for the Tag stacking, you should move all Material Tags of an object in Object Manager to the left by drag&drop.
Cinema reads the stack left to right. so a Material-Tag left of another Material-Tag means this Material is applied first and below the other material.

You can have overlapping material selections in C4D, they will cause no issues on export.
But you cannot have faces without a material assigned, this will cause a face material inconsistency for sure.

If you’re uncertain if a mesh has every face assigned to a material, just make the lowest material in the stack (the one that is left of every other material tag)
global by not using any material selection for it.
(click on the Material tag, go to the “Tag” Tab and if there’s the name of a polygon selection written in the selection field, delete that text)

BTW: If you need additional information about anything like a Tag, Tool or attribute in C4D, just right click on it and choose help from the context menue.
This will open up the C4D Help Manual and present you exactly the part with the information about it.

I’ve been using C4D even more than usual lately, so I’ll add my two cents:

  1. If you’re building with procedural shapes (lathe, extrusion, loft, etc (AND YOU SHOULD BE THEY ARE GREAT)) turn on “backface culling” for your viewport. Most of the procedural shapes need either their hull or cap normals flipped and they all have checkboxes with which to do this.

1.a. Just as an aside, you have weird disappearing geometry even after flipping normals be aware that C4D doesn’t always like all of your values on procedural shapes to be round numbers. Try adding .001 to a rotation or position value and see if that helps. Same deal for booleans and procedural shapes. This is the worst bug ever but it’s easily accommodated.

  1. Smoothing-friendly import settings in UE: turn OFF normal calculations in your build settings for your C4D-originating mesh in UE. This is the only way to preserve your phong smoothing. Ignore UE warnings about a lack of smoothing groups.

2.a. Also consider turning off “remove degenerates”, particularly if you know your mesh is clean and tidy. This sometimes solves problems with UE messing up carefully cultivated normals.

  1. Apply at least one material to EVERYTHING. Do it. You want to do this. Also make sure everything has a UV map. Without a material a mesh won’t have a UV map. Also if some polygons in your mesh aren’t represented in the UV map UE will ignore them when doing a lighting UV layout. This most often happens if you have weirdo geometry passing through C4D as an import pipeline step.

  2. Go nuts with polygon-selection materials. These are great. These are better than individual meshes per material.

  3. Check your UVs. Quite often the default layouts are undesirable, so at the least go into the UV edit layout and fit all of the polygons to the canvas. If you’re not manually unwrapping, consider letting C4D do a nice programmatic UV layout for you.

If you follow these steps you’ll get great results. If there’s something wrong with your models, chances are it’s covered by an item in this list.

C4D and UE DO work great together but you’ve got the triple check your normals, UVs and materials.

Thanks you guys for your answers!

I think with all those tips and a dedicate analyze of my own workflow I found the way to resolve it! I only tried it over some meshes and I still need to try it out on every mesh, but for now it is working.

So here is my workflow for now. I hope it can help someone else that has the same workflow.

  1. It seem that in Archicad, exporting from the “photorendering settings” allow a better export to C4D (see first linked image). I don’t know why but the meshes look cleaner in C4D.
  2. In C4D instead of delete the default UVW map creating during the export. I keep it, change its name to “UVW0”. After that, I duplicate it, rename it “UVW1” and do exactly JayCox instructions for the unwrap map. Archicad and C4D have a really good connections so I trusted them this time and its look like the auto UV map keep good scale and orientation of materials.
  3. Exporting to fbx (see second linked image)
  4. Importing in UE4 : I change the normal import to “normal and tangent” thanks to Kraid ! you can see in the ultimate linked image the difference between my first import and the new one. The UV scale and orientation look much better.

I repeat it, I only did this process on few meshes, so maybe some errors will occurs in the futur. So don’t take this workflow as the “perfect solution”

During this process, sometimes I get this error "Warning “meshName” has degenerate tangent bases which will result in incorrect shading. Consider enabling Recompute Tangents in the mesh’s Build Settings" it didn’t look to make any problems for now, but it would be great to avoid any error message (except the smoothing error that we can ignore)

I also tried to import meshes turning off “remove degenerates” like Antidamage said, but it didn’t seem to change anything visible for now.

The UVs look everything but ideal for lightmap generation.

Here’s an example how it could be done:
http://www.mediafire.com/download/nbrvbervfjy1x6l/ceiling_test.fbx

Since the bars on top are to thin to cast any noticable shadows on it’s sides, the whole upper part can be mapped planar.

Thanks you Kraid for your tips

But in fact, those “bars” are in reality holes in the mesh (negative boolean). I use them to imitate a concrete floor with expansion joint. here an image in UE4 (without the texture). I don’t know if it will be possible to make only one plan for the top surface with this detail. But you are right, the unwrap map isn’t simple. There is probably a better way to do it manually. This is one of most complex mesh in my project. that is why I tested the uvw creation on this one first.

f0aa692e570d7b23dda64ca874e6def3eade4c04.jpeg

I reexported all my meshes and everything looked good, but when I built up my level I got some issues with those floors, like you saw it Kraid. Look like I resolved all others meshes… that is a good improve, but those one still wrong.


71384144bc25f798f4ab8e8f4bce9df905d214a6.jpeg

Even easier in that case:
http://www.mediafire.com/download/3emg78hdts14vba/floortiles.fbx

If you want a soft transition on the lightmap, keep the sides attatched to the top in Lightmap UVs.
If it needs to be hard and sharp detatch them from the top and provide enough margin between the UV islands.
(read that up on the lightmap UV guide)

Haven’t tested this example ingame yet. so not sure how lightmaps will turn out.
If there’s substancial shadowmap bleeding across the edges, detatching the sides or increasing the lightmap scale drastically would be neccessary.

When i think about it now, it might be best to detatch the sides anyway.
Since the file is allready uploaded and just an example, i won’t edit that now.

Maybe import the fbx to C4D and try to fix it yourself.

Allmost forgot: the issues you see in your models shadowmaps are likely caused by your Lightmap UV layout.
Like the parts with different shading got detatched from the rest of the island and possibly lying distored in another spot on the UV canvas,
where they recive some bad shading from other nearby islands.

Thank you for the example Kraid,

My general understanding of uv mapping and lightmaps are now far better. Unfortunately I didn’t find the way to manually modify the UVW map.

So I exported them to 3ds max and I did the uvw map in it. It look like this resolve the problem even if it is not the best workflow. I mean “dancing” between two different software to do the same process may have worked in this case but doing this in a bigger project or a more complex one will probably slow down the process.

C4D users outside of this forum vehemently defend C4D’s UV editing tools but truth is they’re pretty bad. Simple click-and-drag a polygon? Watch it slip and slide all over the place. Basically a very shoddy tool and mostly unusable outside of automatically laying out hard-edged models.

On the other hand 3D Coat is an amazing UV unwrapper, especially for organic forms. It’s like 3DS Max and then some again. There’s a demo that you can try.

There’s nothing wrong with this workflow, really. In fact you might be less likely to prematurely start UV unwrapping by mistake.

Thanks you Antidamage, I never used 3d Coat. I knew it to be a software similar to Substance but I didn’t know it had a friendly uv mapping toolset. I will try it to see if it fit my needs.

Hi,

You can get the C4D Substance plugin for Free here.
https://www.allegorithmic.com/substance-cinema4d

CHeers,
Wes

I thought they will be adding Substance Integration with C4D R18.
I’ll surely try out if it allready works in R17 though.

I know that C4Ds UV tools are somewhat dated and haven’t recived a major upgrade in years while other programms made huge progress with that.
But they’re not as bad as you make them looking with your post.

In fact i don’t have any major isues doing all my UV maps in C4D and never felt it to be bad enough to transfer my models to other apps just for doing the UVs there.
I’ve done organic and hard surface models, too. I’d even say it’s easier to unwrap organic models then hard surface stuff, since you often have less UV islands to work with, while a well optimized hard surface Lowpoly used for baking highpoly maps onto it, needs to be split into so many small chunks.

Sure, the Tools need an update and sadly R18 doesn’t come with it. (they announced it to be included in the service update to R18)
I just hope they do not decide to push it back to R19 or something.

And there’s the vehement denial :wink: You can’t avoid the fact that the tools are broken and you’re limited to numeric and scripted operations because mouse interactivity with UV maps is objectively unusable. I consider one of the major piece of the UI being unusable to be pretty broken.

Not sure what you’re talking about Antidamage.
I use my mouse all the time to arrange UVs.

The only things i really miss is the ability to work with a customizable grid (e.g. for Lightmap creation)
and that neat UV join feature where you just select an edge and have the adjacent UV piece snap to it automatically.
(i think i saw that in 3dsMax)