Download

Cinema 4D FBX Model Problem in UE4

Greetings

I’ve set up my UE4 for creating Gear VR content.
When I pack the FPS example scene, everything works perfectly fine.
Now I’m trying to get my custom model (a building) to work. It’s made in Cinema 4D and I exported it as a FBX.
When I import it into UE4, it gives me the following Error:484abf8d1b5cc6f13d9de31b39ac18964cc88683.jpeg
I’ve searched around the internet but there seems to be no fix for the Cinema 4D FBX export.
Which 3D application could I try that has proper FBX/UE4 support? Blender?

However, I can still import my model and put it in the scene. But when I pack it for Android (ATC/ETC2), it looks like this:
716a91921090a0ba62b21cf394b684385087b55b.jpeg
It works fine if I pack it for Windows.
I tried swapping normals in Cinema 4D, but that didn’t change anything.

If needed I can upload the Cinema 4D project file, but I’d prefer to not.

Thanks in advance

I see from the ingame screenshot that you have the default mobile touch screen interface still enabled. This can sometimes cause things to not render properly. Have you tried viewing it with the touch interface in your
“Project Settings > Engine > Input > Mobile” section cleared?

Changed nothing, still the exact same problem.
I also tried to just get 4 objects of the model to work, in case the building uses too much vertexes in total.
They didn’t even show up.

I’m going to try to export the fbx from another 3D application tomorrow. Any suggestions which would be the best for that attempt?

I once did a detailed run down on export and import settings C4d to UE4:
https://forums.unrealengine.com/showthread.php?44234-Cinema-4D-Workflow&p=239465&viewfull=1#post239465

This message shows up there too, but this has been that way since the beginning.
As long as the imported model has the right smoothing, this shouldn’t be an issue.

To make sure the smoothing is allright, i’d recomend “baking” it to a normal Tag in C4D using the Vertex Normal Tool (Lite).

Your issue on the mobile build looks like a graphics glitch of some kind.
Calculation errors during geometry calculation.
I’m not exactly sure what is causing this, but i doubt it is related to the smoothing groups warning.

Maybe the model itself is to expensive for mobile.

I followed this guide, but I still get the same result.

I’ve tried Unity now and it works flawlessly there, so I guess the problem is on the UE4 side.

Maybe there’s something in the model properties that tries to optimize the meshes for mobile, but in this case causes issues.
Check the mesh properties especially for stuff liike that. Maybe it’s just a checkbox labeled e.g. “combine meshes” to uncheck.

Couldn’t figure out anything. I’ve tried to export with all kinds of check boxes enabled/disabled, but I got always the same result in the end.
I don’t have time and energy to further try what could cause the problem, so I’m doing it in Unity for now.
But if anyone still has an idea or possible fix, please let me know.
Thanks.

I have the same problem . Did anybody found a solution?

A few more details would be good.

What Version of Cinema 4D are you working with?
Which export settings are you using?
How is the model setup and how complex is the model (vertics-, triangle-count, number of materials, etc.)?
What UE4 version, template and setup are you running with?

Ofc. screenshots or even a file of the model could help with tracking down the issue.

I’m experiencing the same problem with 4.14 and earlier versions, the *.fbx coming from 3dsmax. when starting on pc everything is fine, on the mobile its not showing correctly. have testet packaging with etc1, etc2 and atc so far. working with a samsung galaxy s7.
are there any soultions by now?