Chunking in UE5 Preview 1 not working for windows platform


I am trying to use Patching by using chunking and then cooking them into .pak files. I am creating Primary Asset Labels for the characters as suggested in the Preparing Assets for Chunking | Unreal Engine Documentation tutorial.
This works correctly in the UE5 Early Access version and the chunks are visible inside the Asset Audit for both Editor and Windows platform after Packaging.

Inside UE5 Preview 1, the Editor platform shows the correct chunking.

However, only a single chunk file is visible for the Windows platform.

As a result, when I package my game, only a single pak file is generated.

Has anything changed or are there any changes that I need to make for chunking to work correctly in UE5 Preview 1?

Got the same problem in 5.0 did you find a solution?

I’m using Unreal 5.1.1 and I’m still having this issue. It may be some wrong configuration or the fact the my game uses Lyra as the starting point. But I’ve tried many different things for a while now and nothing seems to work.

I am also trying to deal with this problem. It seems to work fine so long as it isn’t for plugin. I was able to make two levels, one titled “MainLevel” and the other titled “SecondaryLevel.” I also made two Primary Asset Labels, one called “MainContent” and the other labeled “SecondaryContent.” MainLevel was specified in MainContent, which had priority 1 and chunk ID 0. SecondaryLevel was specified in SecondaryContent, which had priority 1 and chunk ID 1.

With the Force One Chunk Per File option checked in the project settings, this worked as expected. However, as soon as I attempted to apply this sort of setup to Game Feature Data and assets used by the game feature plugin, nothing worked. It seems like there’s something going on with the way it deals with plugins that’s overriding the chunks I’ve assigned, but I can’t be sure…

EDIT: It seems like patching for Windows is all based on the platform-agnostic patching method found here? Which doesn’t really seem to make sense. There’s no reason a plugin shouldn’t be able to be contained in its own pak, and the thread here seems to suggest that it’s totally possible. But I can’t seem to figure it out. Why is windows so… windows?

The “Build DLC” option seems to work for making the plugin into its own pak file (sometimes requiring the “Include Engine Content” option), but the pak file doesn’t seem to load in automatically despite documentation saying that pak files in the /content/paks directory are automatically loaded. Very confusing… I also tried just using unrealpak.exe to manually make a pak of the relevant files, but that doesn’t seem to load in either. Not sure if that’s because the pak isn’t right or just that the game isn’t attempting to load it.

Any Solution? I have the same problem for months now