ChildActors wrong duplicated when Duplicating Level

[4.8.3 binary] When I create a copy of a level map using Right Click > Duplicate; ChildActor components appears twice (duplicated) in the new level map created that should be identical.

I have isolated this bug so you can replicate using clean new project with 2D sidescroller template:

  1. Create a new simple blueprint with a PeperSprite component, and set any sprite. Named TMySprite.

53047-01_createsimplebluprint.jpg

  1. Create a second blueprint (TSomething) and add a ChildActor component, setting class to TMySprite.

  1. Place TSomething in empy level ( NewLevel ). Until now everything fine.

53049-03_placetsomethingintonewemptylevel.jpg

  1. In content browser duplicate NewLevel to clone this map using Right Click > Duplicate.

53050-04_duplicatelevel.jpg

  1. Open the level copy NewLevel2. Now a second TMySprite appears as Child of TSomething.

In more complex project this issue is very annoying, the only workaround I have found is to fix manually every problematic blueprint, after duplicating my maps. I have to re-place this blueprint and delete duplicated child actors.

I’m sure this is a bug, if not, please tell me what I’m doing wrong.
Regards,
piX

Hi piXelicidio,

Thanks for the report! I was able to reproduce this in 4.8.3 as well as our internal builds, and I’ve created a report for the issue (UE-19748). I’ll post here when I see any update on it. Thank you!

Using “file->save as” you can make a copy of your current level and everything will be fine. No duplication problems.

May seem obvious but I though should make this note in case some one find same problem and miss the “save as” alternative.

I can confirm by testing this problem is still present in 4.9.0

It’s only me… or Right Click → Duplicate for maps was removed in 4.10.0?

It’s not just you =)

The developers disabled the duplicate option for worlds to eliminate the possibility of various other crash problems until a full fix for duplication in content browsers can be created (UE-22200). For now, your File > Save As solution is the best option.