Child components not following root component even though they're supposed to be attached to the root component

I have created a SceneComponent on a blueprint within c++ which I use as my root component and assign it as such in the constructor:
image

image

And then of course I attach the other components to the new RootComponent:
image

And it looks all fine within blueprints:

However, the moment I drag it into the world not only is there a weird line separating the root component from the other components:

But moving the root component itself does not make the child components move, they have to be moved separately for some reason.

I’ve tried so many different functions and FAttachmentTransformRules but none of it seems to be working at all, any suggestions?

bump.

Such a buggy engine, if anyone is curious to know the solution, restarting the engine actually worked for me, so im just gonna leave this for anyone else in case they are having the same problem, cause I know I sure as hell spent the last 8 hours trying to find a solution to this.