Child Actor Component Visibility Bug

Build Type: Source

Build version: 4.15.0-0+++UE4+Release-4.15

Detailed description of the issue: The child actor visibility is buggy. I added a child actor and made it hidden(Visible and Hidden in game were unchecked). Then with a push of a button I tried to make visible using “Set Visibility” and it didn’t work at all. Toggle visibility works, but I need to toggle it on, then off and on again before it works. I tried it in an empty project and it happened again. Check the video below for a better view of the problem.

Screenshots/Link to video: Video

Repro Steps

Action 1: Create blueprint blank project

Action 2: Create an actor with just a cube.

Action 3: Create an actor with a sphere. Add a child actor component and select the actor with the cube(from Action 2). Move it a little bit so they dont overlap, and make it invisible, by unchecking "Visible" in Rendering settings.

Action 4: Make a simple world and some lighting and drag the 2nd actor (Action 3) in the world.

Action 5: In the world settings, with a push of a button, use "get all actors of class", and select the actor you placed in the world. Get the first entry from the array, get a reference to the child actor component, and use "Toggle Visibility" (or "set visibility"), and check "Propagate to children".

Action 6: Test it!

Hi DjSt3rios,

Thank you for the report. I was able to reproduce the issue, so I have logged it as JIRA UE-42240. Our developers will be investigating further. Follow that link to monitor the status of the bug report.



Hit something very similar to this in 4.22.3 on iOS

On Windows, child actor hidden in game respected but not on iOS.

Workaround - reset child actor class until needed

Hi Michela, do you mind describing the workaround better? I am not sure how to reset the child actor class.