Download

Character Spawning Outside the Level Environment

When I click “Play”, it spawns the character way, I’m talking way, way, way, outside of any playable area. The character simply falls forever. It does this no matter if I move the PlayerStart actor or select to spawn the character at the current camera location.

If I delete the PlayerStart actor and add another one (or add any actor), I get an error message saying “The actor will be placed outside the bounds of the current level. Continue?”

Any ideas how to get it to spawn at the PlayerStart?

Edit - I no longer think the character is spawning outside the playable area. Instead, the level is disappearing.

Before I click play, there are over 5,000 actors.
After I click play, everything disappears and there are only 19 actors.
After I click play, the only thing I can see, besides the Third Person Character, is the default floor, which I added just to be able to see something. Depending on where I position the PlayerStart, the Third Person Character can stand on the floor. Nothing else is present.
When I click Stop, I can see the level from the viewpoint of the Third Person Character. In this case it is from below since the Third Person Character was falling.
It seems that clicking Play makes everything go away. Maybe the level and character aren’t part of the same environment, but if that is the case, how do I combine them or make it so that the character spawns in the world.

The checkbox for World Origin Rebasing is not checked.

Thanks.

Assuming the spawn point is with in the map this can occur when there is a static object with a collision that encompasses the area that the spawn point is with in the collision. UE4 knows this would be a non-valid spawn point and push the player capsule to the outer limits of the collision. This can happen when a object is imported with auto-collision set.

I just turned off all collisions and the same things happens.

I do move the spawn point to where I want it inside the level, but that doesn’t ever change anything. Maybe the world environment is actually outside the bounds of the level? How would I correct this?

I’m worried about the error message I receive when trying to add a new PlayerStart, “The actor will be placed outside the bounds of the current level. Continue?”

You are using world composition and placing the Spawn point into a level it shouldn’t be in.

You either place it in persistent, or load the individual level and place it within the level.
Both solutions can lead to issues when you use world origin rebasing.

However using the persistent works. You can Spawn at any location and the landscape levels will (eventually) load in.

It says, “Selected Actor(s) in: Persistent”

I’m not sure how to place the actor any other way. I don’t know how to check the world composition to see if there is a bad spawn point or how to move it inside the level. To me, I’m looking at PlayerStart and it is inside the level. But moving it doesn’t affect the actual spawn point.

Look at the bottom right corner.

[s]Make sure The spawn is not inside a level,
But within persistent.

That’s probably the issue there.

Pull up the levels tab, and move it to persistent.
(Righclick can also do it, for the level details panel).[/s]

Other things to check.
Is world origin rebasing enabled?

If so, are you sure your player isn’t just falling through the floor when you Spawn?
Easy fix for that is to also place a cube under the spawn point within persistent.

The player will fall into the cube. Then you wait for the level to load.

Here is what my Levels look like. Persistent is at the top and everything is nested under that, so does that mean everything is within Persistent?

The character isn’t falling through the floor, but they are spawning somewhere else entirely.

I added a floor, so the character no longer just falls. But the level is no where to be seen.

Maybe it only looks like somewhere else and the level environment simply disappears when I click Play? If this is the case, how do I correct the issue?
Also, thanks for all your help thus far.

You can check by doing a tick print string and print the actor location, and compare it to an actor you place where player start should be which has the same tick print string, but in a different color.

Steps to do this? Sorry, but I’m a noob.

Event tick, print string. Get actor location, and plug that node into the pink thing. Do the same for the other actor. You can go into the drop down (click the arrow) and change the color so you can tell the difference between the two strings.

No, “get actor location”.then plug in the yellow thing into the pink thing.

Here are the results of doing this for the Third Player Character. What other character do I need to do this to?

Also, I can’t add more posts for an hour since I’m new, so I edited one of my above posts with more info.

Good call.

@Gristle_Fang
So you are somehow spawning 7km on x and 11km on y from the center point of the world.

Which has to mean that world origin rebasing is off in your level?

Futher, there’s 2 player start in your level (visible in world outliner).

Delete all of them except one - that should get the spawn system to pick the only one avaliable…

I edited my initial post, largely because I hit the post limit for new members, but also because I no longer believe the issue is exactly what it seemed when I first posted.

World Origin Rebasing is unchecked.

Try checking the box and see if that helps.

Regardless if you only have one player start in persistent and the checkbox is unchecked, then the spawn point is exactly “there” wherever “there” may be.

The only other issue that could cause you to spawn elsewhere not listed in this thread so far, is if you manually place a character in the world with “auto posses” enabled.

I’m sure that the character is spawning exactly where it should be. I think the issue is that the level disappears when I click Play. It comes back when I Stop. It is like the character and level are in two different instances. I cannot see them both at the same time.

I cannot check the box to Enable World Origin Rebasing. The option is greyed out for me.

I’m not sure that’s possible.
For that to happen your level would have to be loaded separately with world origin rebasing being ON.

Since you say it’s off, then this behavior should not be possible. (In theory anyway)

I think you need to figure out how world origin rebasing and the world composition system works.

Check this at x2 speed, skipping around since it’s more chatter than actual doing.

Not sure what else to add.
The character is actually spawning at the location you printed out.

The only other thing that could be happening is that the level isn’t loading - how are you getting the level to load?

Here is a link to a video showing what happens when I click Play and what happens when I click Stop. Hopefully this can help shed some light on the issue.