Character jerking with Movement Replication Bug?

It only occurs on the clients the host does not encounter this issue at all. Two examples of the issues on clients once they connect!

Sorry for the music! Mute the video - >.>

Hello ,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints that may be involved with this issue?

Im going to try it in a Third Person demo template and check to see if replication works. Give me a few hours

Working on that now!

its a combination of C++ and Blueprints which sections would you like? I can upload it to pastebin or rar up the code? I know it has to be something in my Character CPP or my Blueprint…

Hey I am also on this project and as a added note to the issue,

Only the client has this bug when connecting to a listen server.

If the server crashes the client remains in the game and the issue no longer happens. However the issue is only resolved if the server crashes.

I cant get the third person demo template to play as a listen server it just crashes as a template for me to test to see if replication works out of the box for the movement. Im using the C++ template version. I start the server on my computer with the listen command added and when the client joins the server computer freezes and i have to Alt tab to crash the exe. I also tried adding more player starts to see if that would resolve it

I use the following command . Open test?listen

Nvm: I solved it by hosting the game on another PC and joining with another and it finally works. Guess UE4 just doesnt like the computer i was hosting on first . It does not jerk on the Third Person demo as switching hosts what should i do?

Hello ,

Would it be possible for you to provide a simplified version of the project that reproduces this issue so that we could take a closer look? If you would like to provide it privately, you could do so by zipping it down and providing a link to google drive or dropbox in private message to me on the forums.

Our UE4 Repo for Dark Storm is like 20 Gigs between the VR-Singleplayer and a GameJam Submission we did. Umm give me a few to wrestle around a way to get you these files. In a form that would work. Question though ive been tearing about my code left and right and striping it down to the bare essentials and ive noticed when i do that and disable everything in the BeginPlay & Initializer it resolves the issue. But im having a hard time figuring out which of these could be the culprit. Ive tracked it down to a C++ bug. Here is the code excerpts that work and no longer lag.

Ive sent a link to Pastebin where ive uploaded one paste of my old code that does have the replication bug and the code after tweaking it which is at the top that doesn’t have the replication bug. but i still really need to know what line could have caused it so i can learn from my mistake and avoid it in the future. Since each build takes 20-40 minutes before i can load it on a computer its extremely time consuming between testing slight alterations of code your expertise would be invaluable in helping me solving this >.<

I have reverted my code after committing the fixed version to my svn so i can easily hop between the two and im still continuing to comment out lines and copy over code from the fixed version to test it and figure out what solved it.

If you guys from Epic could take a look and tell me whats the cause that would help greatly

The Non Working Code starts at line 441. Everything above is the version of that code i aggressively tweaked

Hey ,

I have looked over the code and while I cannot tell you any one specific line that is causing the issue, I can give you some recommendations.

To start, I would ask for you to create a new Character C++ class and give it your character Skeletal Mesh and a Animation Blueprint and use that as your DefaultPawnClass, which is assigned in the GameMode you are using. With that in place, test it out again and see if you are still having this issue.

Secondly, I would suggest going through your Character and Controller classes and clean up anything you aren’t using or don’t need to assign; including anything that is redundant.

As an example:

109: FollowCamera->FieldOfView = 90;
122: FPSCamera->FieldOfView = 90;
127: FPSCamera->FieldOfView = 90;
128: FollowCamera->FieldOfView = 90;

While this probably doesn’t cause an issue in itself, if this continues through other portions of the code, it could cause an issue.

Lastly, I would recommend that if you are replicating anything that you are doing it for a purpose. By default the Character class is replicated for its movement. If you are are doing something on top of this, as in replicating the Character position on top of the normal replication, you could have some issues.

Hmm I will do this now and will remove redundant data. Currently I am not replicating anything besides outfits to sync and attach at spawn in my post begin play. Give me a bit I’ll give it a try. Do you notice any other suspicious code I should comment out in the original besides the redundant lines like fov etc? I can try as well

Also do you know why this only occurs when you actually compile the game? It never occurs in the PIE with multiple players set it makes it extremely hard to test for? Just another thing to note ^

Hey ,

Do you happen to have a Spring Arm Component that has bEnableCameraLag enabled? There is a issue where that will cause the SkeletalMesh it is attached to to jitter around.

You can see the issue here:

If bEnableCameraLag is false (off) and you are still having the issue, then its not related to the issue report.

Thought I’d mention it, just in case.

yes i do! but i recently turned it off to test something else could that be the cause?

I had a similar issue like this with one specific animation. The animation would twitch if ‘Replicate Movement’ was on. My solution/fix for this was to temporarily check ‘Ignore Client Movement Error Checks and Correction’ in the CharacterMovement component.

EDIT: Don’t do this if you intent to properly replicate stuff. I wrote this years ago and I was just not replicating stuff properly at the time. There’s an error in your replication somewhere lol

I attempted to remove the camera lag from my spring arm and my problem persists. However, when I attempted to use your solution to check ‘Ignore Client Movement Error Checks and Corrections’, my problem was resolved. So far I haven’t seen any issues with this! Can someone give me a good example of what issues might come about from having this option checked?

Thank you very much.
Checking ‘Ignore Client Movement Error Checks and Corrections’ fixed my issue.

, if you haven’t already, make sure that your static mesh isn’t being replicated. However, you should still have the the character replicate.

Dark, you would be surprised how many issues spawn from testing a packaged game. Patience is the only solution!

It is replicating. I ended up unchecking that option, because it caused more harm than intended. I fixed it by changing some other settings. Thank you for reminding me anyway!


Man you are awesome you fixed my problem I was having. Some how mine was checked to replicate. Thanks Debaucher!