Download

Character hand is getting stuck to the physics cloth (Solved)

I have tried everything and double checked my skin weights, my physics weights, messed with all the settings, even remade my character 5 times in Character Creator 3 using different methods to outfit her before importing her…I even tried making her forearm physic collision long and even deleted it completely…but the physics of the bottom part of the jacket is somehow following her sleeves on the jacket…It only does this in-game it does not do this in iClone with physics…or when I open the animation in the editor…it only does it in-game. Any help would really be appreciated.


Your cloth is way too loose.
Have a look at this.
The paint is supposed to be gradual like in the example.

Alright I’ll watch the video and see if that helps. I did try redoing it and it had no effect on it. I made it all pink, painted a white bar across the bottom at 5 and selected smooth until it had a smooth gradient but it still did it but maybe I shouldn’t have used white.

White is just “full” value of whatever you set as the base length multiplier.

There’s only a few ways that the hand could be causing the mesh to move.

Do also check that the clothing isn’t accidentally weight painted to the hand.
Unlikely, but possible.

The other reason is an incorrectly setup PHAT asset thats causing the snag by being inside the clothing and moving with the arm.

Yeah I did double check that…that was my first thought but then I would have noticed it when I was running my checking poses before export. I did check anyway and there wasn’t any that I could see, as far as it appeared the person who made the outfit did the weight paints flawlessly

What is this PHAT asset? I’m not familiar with that. Scratch that, yeah the physics body collisions I checked those and tried moving and making the forearm capsule larger and even removed it and it didn’t seem to have an effect on it

From the screenshot it could be a single vertex weightpainted to the hand.

Try this real quick.
Make a version of the asset with removed weight paint.
Enable the cloth and place it on there.

See if without weight paint the hand is still catching onto it somehow.

If it doesn’t, it’s a weightpaint issue.
You can look at the specific hand vertex groups to figure out which one went rogue.

If it does… please share a screenshot, that would be interesting to see…
Particularly because the cloth won’t follow the arm up.

Hey thanks for the response and the aid man, I’ve been on this for like nearly 2 entire days now. So I added physics too the sleeves and they no longer catch to the skirt of the jacket. I still want to get to the bottom of this and find out exactly why.


I hide the mesh under the clothes so I’m not sure if I should just add a tiny bit of physics to the inside enough so it doesn’t stick but the sleeves don’t fall or keep trying to find the root reason for it…I considered maybe the UV’s were too packed and causing bleeding issues as well.

The nvidia cloth implementation is beyond bad.
Though I have never had similar issues, it could be just about anything, including things you have no control over…

Chaos is apparently worse. I really didn’t waste time testing it past a peripheral check in which it was clear performance was still not even remotely checked.

re the sleeve.
Hiding the mesh is always best. otherwise you just get clipping issues.
This is mostly because the backstop cloth parameter was never implemented correctly according to nvidia specs. IF you could rely on a backstop you’d get much less clipping on properly set up assets.

IF adding cloth to it make the issue stop - could the problem be one of the verts on the sleeve painted to the thigh/pelvis?

If it helps any, UE4 cloth is about as helpful as a t-1000 :stuck_out_tongue:

1 Like

I double checked the skin weights on the cloth and I couldn’t find any verts painted to bones they weren’t supposed to be painted too. I should point out if that were the case though, the same thing would be happening even with physics turned off.

Very true.
Weight paint follows whatever bone.

The phat asset has to be at fault then.

Try creating an empty phat to see if the distortion still happens.

If it still does, and it’s not the paint, and it’s not the phat, then you can blame unreal.

It probably won’t help any since they ignore all bug reports anyway…
But at that point you should file a ticket and share the asset with the epic team nagging them to fix their cloth stuff… since you isolated the issue as to being the cloth.

My money is still on the phat asset having something strange to it that is pinching the cloth.
Just because that’s what happens about 1/2 of the times something wierd happens with cloth.

If you figure out what it is do let us know. It may help someone else down the line.

Yeah for sure I’ll try that a bit later. I think I need to kick back for a bit and watch a show to take my mind off it for a moment lol

Yeah I don’t think it’s the physics collision. I removed it and it still did it, redone it…still did it. Even used a physics asset from the paragon and tried the UE4 Mannequin and it still did it. So far the only solution has been to Add physics too the part it’s sticking too…Now today I did notice when I first opened up my project and simulated it wasn’t sticking to the right sleeve, only the left sleeve…I thought that was pretty odd…Later it started doing it for both but I’m not sure at what point it began doing it again.

I think this may be why I’ve been having problems…it starts the animation with her sleeve clipped into the jacket.

Update: So I think I’m going to give up on this and just disable physics for the front and sides…I can’t figure out what’s causing it…The physics system is ■■■■ and sensitive and not well documented. I have some strange but that apparently no one else has and have no ideal why. I have pretty much tried and checked everything. Thanks for the help but I can’t spend another day trying to figure this out.

Note: The only solution I can recommend if you get this is to try and work your weight paints so that it’s solid pink around the areas your hand is pulling the fabric

Disable the self collision option.
It’s probably snagging on itself because of interpenetration forced by the starting pose…

Yeah I tried that it just causes it to ignore the collision physic shapes on the legs and it still gets stuck on the wrists

Self collision should cause it ignore collision with it-self, not with the capsules inside the PHAT asset.
Are you sure you toggled the correct parameter?

I’m assuming you were talking about this, if so then yes it disables collision with the PHAT asset