Character commonly falls through landscape mesh

In addition to “RecreateLandscapeCollision”, it did not work for me.

Thank you for the steps. I am currently re-installing 4.5 to test landscape conversion (if this does not reproduce it, I will scale back to 4.4 to be safe) and will follow the steps provided to attempt reproducing this error. I will post here once I have additional information.

Thank you!

One additional observation, it appears that any attempt to modify the landscape fixes the problem temporarily as long as you keep the editor open!

Here is what I did as an experiment:

  1. Manage Landscape

  2. Edit Splines / Tools Setting / Deform Landscape to splines: All Splines w/ Use Auto checked

  3. Rebuild Pathing

  4. Now NavMesh builds correctly in the area where Players and NPCs used to fall through the terrain

  5. Everything works fine until you close editor

  6. Exit/ Restart the editor the same old problem reappears!

The same thing happened when I tried “Change Component Size” in the Landscape editor.

Is it possible that something in the landscape is not being serialized properly?
Hope this helps debugging the issue.

Can you send me a sample project that is showing the errors you are describing? I have been attempting this but have yet to be able to reproduce the error on my end. Any additional information or assets that could lead to this reproducing would be greatly beneficial. Thank you!

Unfortunately Sending you a sample project would require “Management approval” BS, however I think I found a workaround which maybe the permanent solution!

This worked for us:

  1. Landscape Mode / Manage/ Selection Tools / Go To Change Component Size

  2. Set Resize Mode to "Resample (leave everything else the same)

  3. Apply (this may take a few seconds)

  4. When the process is complete/ build pathing if u have NPCs /

  5. Save close the editor

  6. Reopen editor / test / Player should no longer fall through the terrain

Hope this is not just a workaround but a solution to this issue, please let us know if this works for everyone.

Thanks!

Can everyone try these steps and let me know if they work for you?

Hey there, yes I simply re-sampled the terrain and it worked. I haven’t saved it in case you need the project or want me to try something else (it is 1Gb though…).

This does appear to be a real bug.

Can you tell me whats going on so far with this?

PS. I just moved over from Unity and this engine is awesome!
But why do all my characters import as a single object in the World Outliner, why is their no hierarchy like in Unity where I could enable, disable childs?

An example would be I have 5 heads on the character, player presses a button and it switches between heads visible.

If you need further testing since on the terrain bug let me know.

Hi everyone,

While I was unable to reproduce this error on my end, we have had a number of users experience this collision bug. I went ahead and put in a bug report, UE-11447 to be assessed by the development staff. Can you try the workaround vkirazian suggested to see if it fixes the error you are seeing? Thank you!

Hi, we’re experiencing a similar issue since moving to 4.7.

Our character is falling through only a specific part of the Landscape. I tested to see if the retopologise tool was creating areas of bad collision, but that doesn’t seem to be the case.

Resampling the landscape seems to fix the the collision problem, but all of the layerinfo we’ve painted gets messed up, so textures aren’t where they should be, so it’s not really a good fix for us.

Same problem here.
If I try to resample the landscape He moving in bad position…

Only solution for me is to reimport the landscape file, but i lost my light build…

Hi guys,

We just fixed a new bug in 4.7 where collision for landscape components containing XY offset data (generated by the Retopologize tool) was broken. The fix will be in 4.7.3 which should be out next week. If you’re using source code you can apply the fix directly before then if you’d like:

https://github.com/EpicGames/UnrealEngine/commit/cbaaca1e870bce1aae32ba5d0c7dcd48c7b6aea2

Cheers
Jack

Same issue with me, I went nuts with the retopologise tool and now my landscape is like a sieve.

Hey,

I’m having the exact problem. Have you by now found a solution that doesn’t give the textures issue? As my map is quite big and starting to get detailed i wouldn’t want to redo it. Or is the texture weirdness only on the places it’s messed up? Repotologize didn’t do it either for me. Only when i seem to not use my landscape on a certain location for a while this starts to happen. So the question, any fix yet?

Greets,
celeste

4.7.3 resolved my landscape’s collision problem.

ciao

A word of warning. The landscape collision plugin, that Rama posted, totally corrupted my project. So make a backup before you try using that.

For me too.

I just wanted to say that I am experiencing this problem in 4.10.1.

Is there a more recent fix for this?

Thanks,
Garrett

Hi garrettorious,

This was fixed back in 4.7. Can you list what steps you are taking to reproduce this on your end in a clean, blank project with no additional content? I’ll be happy to take a look and see what may be occurring.

I’m also experiencing this in 4.10. It’s something that happens only when you create hills/valleys. I have a riverbed and the character sinks up to their waist when they go down the slope.

HI 0vr,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What steps can I take to reproduce this error on my end?