Character Child Class Skeletal Mesh Default Issue

I have a Blueprint child character class that is clearing it’s default skeletal mesh that it inherited to none every time I reload the editor. I was wondering if anyone else has ever ran into this issue and could help.

Hello ,

Could you explain how you’re setting the skeletal mesh? Where did it inherit the skeletal mesh from?

Thank you for the quick reply. I set the skeletal mesh component under the defaults panel inside the parent blueprint. I found a fix, but I’m not sure it should have to work this way. I just set the parent default mesh to none. Then set all the children to use the desired mesh.

That is not how it’s suppose to work. I tried to reproduce the problem in the most simple way I could think of. I made a project with the Third Person Template and then made a child blueprint of the ThirdPersonCharacter. It inherited the skeletal mesh and remained after closing and reopening the editor. Could you provide any more details as to how to reproduce this? If we can get a reproduction case, I can report it as a bug to be fixed.

I tried setting the parent to use the mesh and it still is causing the same issue. The funny thing is I’ve created two classes a player and AI class. The AI keeps the mesh and the player still recognizes it as it’s default. If you click the yellow arrow next to the mesh slot it goes back to the default, but for some reason it’s clearing itself on editor startup. Is there any way to get my project to you? I’ve attached the player blueprint pasted into a txt file.
link text

If you wish to send your project, the easiest way would be to upload it to a file hosting site such as Dropbox, Mega, or Mediafire and then provide the link. If you wish for the project to remain private, you can send the link via a private message on our forums. [Here is a link to my profile][1] if that is what you want to do.


We haven’t heard from you in a while, . Are you still experiencing this issue? If so, have you had any chance to upload a copy of your project? In the meantime, I’ll be marking this issue as resolved for tracking purposes.

I am also having this issue currently. When I reload the editor, the skeletal mesh of my child actors is set to none. The setup is a Parent with two Children, and both suffer from this error. However, the parent’s skeletal mesh selection remains intact. Your issue seems to be exactly the same as the one I’m having. A co-worker has posted this issue here: [Bug] Skeletal Mesh Disappears after closing editor for Child BP - Programming & Scripting - Unreal Engine Forums

Thank you for sending me the project, . I’ve taken a look at just used the process of elimination to see if I could try to find a bit of context to the issue. I migrated the child blueprint (And anything it was referring to of course) to a new project and then started deleting stuff to see if anything could cause the problem to stop happening. After mass deleting the Effects, UI, Weapons folders and some animations, it’s not happening anymore. I’ll be looking deeper to find out the exact cause but I can at least say we’re getting somewhere.

It seems to be related to the BP_BaseWeapon in some way. I was still using the process of elimination and upon deleting that particular asset, the issue stopped occurring. Could you try looking into things around that scope and see if you can find something that may be linked between the two assets that could cause this?

Have you had a chance to look into this issue, ? I was able to narrow down the issue quite a bit but it’s up to you from this point to find the cause as I’m not very familiar with the inner workings of your project.

Same thing happens to me in 4.10.4 any fix for this?

Hello Axxi,

I’ve been attempting to find a solution but seeing as every reproduction I’ve gotten so far has relied on a user’s project, I haven’t been able to get very far. Do you know to get this issue to occur from a fresh project so that I could reproduce it without needing to rely on an already hefty project? It’s much easier to narrow down the cause if we can get it to occur from scratch.

i have a complex bp so as you can see all of the poeple that experience this have complex blueprints and noone of them can replicate it in a fresh project , i fixed this by changeing the editor startup map to another one

I have started to run into this issue with a vehicle in 4.11. The parent vehicle blueprint retains the skeletal mesh and animation bp, but the child class that uses the same mesh that is inherited goes to none.

Strangely enough, a child bp I have where I previously changed the skeletal mesh but kept everything else remained intact. So only the child bps using the same exact skeletal mesh are running into the problem.

I also tried rolling back to a previous changelist in perforce and still had the same result immediately upon reopening the project.

Hello FelRod,

If you have time to work together with me on this, would you be able to provide a sample project that reproduces the issue? We could work together to find what exactly is causing this to occur. The issue up to this point is that I’ve gotten reproduction projects but nothing narrowed.

I’m having a similar issue with our character blueprints. We have 4 player characters, 3 male and 1 female. The female character seems to be immune. But the male characters, as soon as they are selected a game and we reload the editor, the models disappear or their translation and rotation values in the blueprint are gone. Very weird stuff. So I’m keeping an eye out here in case some solutions pop up.

Hello ,

As mentioned with my comments to the previous users, this seems to be a content issue and related to the way these projects are set up. If you would be able to provide me with a sample project that reproduces your error and work with me to narrow down what is causing things to go wrong, I would be happy to help.

Hello ,
I’m experiencing the same problem: the children vehicles don’t inherit the anim instance of the parent. In the text box and drop down menu you can see the blueprint but in game the vehicle’s wheels don’t turn. This happens in 4.14.3 and 4.15.1, only tried these.
I have the project, which is the multiplayer tutorial that I was modifing to suit my needs, I can send you a download link.

That would be helpful. You can either link it here or send me a private message on our with the link.