Chaos Cloth Panel Consistently Crashing at Skin Weight Transfer

There is always the major potential I am doing something wrong, either in the MD cloth exporting itself, or the character’s skin weights, however beside that I have followed the Cloth Panel Tutorial exactly.

I cannot find anything since it’s release that point to this being common. and I know this is experimental…

Any direction towards making this work would be grandly appreciated
thank you!!!

Screen Recording of the process and exactly where the crashing is occuring

Crash report copy paste

Fatal error!

Unhandled Exception: 0xe06d7363

0x00007fff8d54cf19 KERNELBASE.dll!UnknownFunction
0x00007fff7bdf6720 VCRUNTIME140.dll!UnknownFunction
0x00007fff7bd9b522 MSVCP140.dll!UnknownFunction
0x00007ffec8b235a0 UnrealEditor-DynamicMesh.dll!UnknownFunction
0x00007ffec8bcbd40 UnrealEditor-DynamicMesh.dll!UnknownFunction
0x00007ffec8bcc8bb UnrealEditor-DynamicMesh.dll!UnknownFunction
0x00007ffec8bcccda UnrealEditor-DynamicMesh.dll!UnknownFunction
0x00007ffec8bce5d5 UnrealEditor-DynamicMesh.dll!UnknownFunction
0x00007ffec8b1b34b UnrealEditor-DynamicMesh.dll!UnknownFunction
0x000001cd5183401c UnrealEditor-ChaosClothAssetDataflowNodes.dll!UnknownFunction
0x000001cd51833c53 UnrealEditor-ChaosClothAssetDataflowNodes.dll!UnknownFunction
0x000001cd517fb25a UnrealEditor-ChaosClothAssetDataflowNodes.dll!UnknownFunction
0x00007ffee6060306 UnrealEditor-DataflowCore.dll!UnknownFunction
0x000001cd504ccc5e UnrealEditor-ChaosClothAssetEditor.dll!UnknownFunction
0x000001cd50504cf9 UnrealEditor-ChaosClothAssetEditor.dll!UnknownFunction
0x000001cd50586615 UnrealEditor-ChaosClothAssetEditor.dll!UnknownFunction
0x000001cd5054eb20 UnrealEditor-ChaosClothAssetEditor.dll!UnknownFunction
0x000001cd5035971a UnrealEditor-DataflowEditor.dll!UnknownFunction
0x000001cd50389cf0 UnrealEditor-DataflowEditor.dll!UnknownFunction
0x00007ffef126c516 UnrealEditor-GraphEditor.dll!UnknownFunction
0x00007ffef128517e UnrealEditor-GraphEditor.dll!UnknownFunction
0x00007ffef1209e62 UnrealEditor-GraphEditor.dll!UnknownFunction
0x00007ffefb0f3b5a UnrealEditor-Slate.dll!UnknownFunction
0x00007ffefb15e365 UnrealEditor-Slate.dll!UnknownFunction
0x00007ffefb14b562 UnrealEditor-Slate.dll!UnknownFunction
0x00007ffefb13e2fa UnrealEditor-Slate.dll!UnknownFunction
0x00007fff428a7dc6 UnrealEditor-ApplicationCore.dll!UnknownFunction
0x00007fff4288b83f UnrealEditor-ApplicationCore.dll!UnknownFunction
0x00007fff428aab29 UnrealEditor-ApplicationCore.dll!UnknownFunction
0x00007fff428832e3 UnrealEditor-ApplicationCore.dll!UnknownFunction
0x00007fff8e46e858 USER32.dll!UnknownFunction
0x00007fff8e46e299 USER32.dll!UnknownFunction
0x00007fff428ac226 UnrealEditor-ApplicationCore.dll!UnknownFunction
0x00007ff6548176f2 UnrealEditor.exe!UnknownFunction
0x00007ff65483d28c UnrealEditor.exe!UnknownFunction
0x00007ff65483d37a UnrealEditor.exe!UnknownFunction
0x00007ff654840854 UnrealEditor.exe!UnknownFunction
0x00007ff654856984 UnrealEditor.exe!UnknownFunction
0x00007ff654859d7a UnrealEditor.exe!UnknownFunction
0x00007fff8e1d7344 KERNEL32.DLL!UnknownFunction

1 Like

I am running into the exact same issue.

1 Like

I was initially using a mesh with many material slots (13) and simplified them to be 3 slots and did not observe the crashing anymore. @FaradayPrime Perhaps you could try reducing the number of material slots?

Have you fixed it, sir?

I’ll just throw my hat in and say I’m having similar issues. I’m getting crashes that say something like:

Assertion failed: FaceVertex == TVec3(INDEX_NONE)

If it doesn’t crash, I’ll get a message like: TransferSkinWeights: Transfer Weights Failed.
image

I’m not sure if its the skinned mesh character I’m trying to use, or the render mesh or sim mesh (all are just using one material). It seems to crash more consistently if I add the ClothAssetTerminal node into my graph.

Definitely seems to be in the experimental phase, maybe Epic could provide more guidance on the types of meshes that will / will not work with the Panel Cloth pipeline.

I tried two methods to fix it. One is to add material at solt in character. One is deleted all bone except deformed bone.

It’s completely unpredictable for which cloth it will crash and which is ok.
I successfully added quite complicated female clothing but failed with a simpler T-shirt.
I had the same error D_Chap posted, tried to use merge by distance in Blender tool, but even I reached to loose quality, the crash still here.
I don’t think it depends on complexity/number of faces b/c my successful cloth was the most complex. Hopefully it will be fixed in 5.4 (or at least UE should show some informative error instead of crash).

I solved this problem by fixing the fbx file. In my case, the error occurred after exporting fbx from zbrush. I’m using 3ds max, but even re-exporting the model from zbrush doesn’t help.
I fixed this by selecting all the polygons in edit poly mode, then detach it. After this, the smoothing groups are lost, but most likely this is not a problem.
I haven’t tested it, but I advise you to export the mesh in obj format and only finally export it to fbx via 3ds max or better maya

Hey there! I’m having the same issue. Have you managed to find a solution?

Im having the same issue. I even used default cloths from marvelous and changed particle distance to 25, crashes constantly. I have been pulling my hair for weeks intermittently testing different cloths and methods.