Changing World to Meters scale at runtime disrupts HMD rendering on HTC Vive

I’m setting the World to Meters scale value at runtime in my VR game. It was working in 4.17.2, but it’s broken in PIE after I updated to 4.18.1 (I haven’t checked in Standalone yet). I saw there was a similar issue in the 4.18 Preview for the Oculus that got fixed, but the bug is not public so I can’t check it (UE-49386). Could you please make it public?

Even when I set the World to Meters directly in the World Settings, it’s broken. It blinks and the view moves when you turn your head.

It’s a show stopper for me.

Most probably related to this bug i posted here:

Feel free to upvote my bugreport too to hopefully catch the attention of the devs. Like you, the change of World To Meters are a showstopper for me too, even though the symptoms are a bit different.

I was suspecting that the AR/VR Camera refactoring done in 4.18 had something to do with my issue. So I opened my PlayerPawn blueprint to look at the CameraComponent. And after doing that, the bug is gone \o/

So perhaps the CameraComponent holder blueprint had to be re-compiled/saved?

Good to hear, as mentioned, i think my issue is different since it’s offsetting the floor. I don’t suppose you get that? Ie. if you set the world to meters to 200 and play.

Not sure what you mean by “offsetting the floor”. Setting to 200 makes you giant, right? In this case, if you are perfectly in the middle of the VR area, your position won’t change after changing the World to Meters scale. But if you are not in the middle, after increasing World to Meters, your position will be twice further away from the middle of the VR area than before. The chaperone center should stay the same.

In my case i see the chaperone floor either as far above the ground or far too low in the ground. Once i exit the editor the chaperone floor is normal again where it should be. It only seem to happen when i change the world to meters, but maybe it only happens if i pause my game.


I have a bug with world scale, mine is different again it seems, since setting world to meters no longer changes your perceived scale in vr (eg the distance between your eyes stays the same) instead all it does is multiplies the tracking input, so setting the scale to 200 I feel twice the height from the floor, and move twice as fast as I do in reel life, but im the exact same scale as at 100… huge problem since the whole point of this game is being able to mess with scale

I think I have the exact same issue. In 4.17 everything worked fine with scale world to meters, but since the spectator mode doesn’t work properly when packaged we wanted to switch to 4.18… after migrating and updating everything this issue occurs when we try to shrink our player (using HTC Vive). The motion controller vanish and the distance between the eyes stays the same and disrupts the view greatly.

Recompiling our pawn didn’t do anything and I don’t know how I can fix this camera issue. Our small game also relies on being able to mess around with the scale. This issue pretty much kills the effort. :frowning:

------------At least this is what I thought until now! My Solution: ----------------

You don’t need to “recompile” or “resave” your camera-holding BP. You need to close every additional tab. Whenever I opened at least one additional tab besides my level the perspective got disrupted after changing the world to meter scale. Whenever I closed every additional tab and only had my level opened, this issue is gone. I don’t understand this issue and it is really weird, but hopefully I could help someone with my approach.

1 Like

I have the same issue as Cheese Dragon it seems. As soon as we change the world to meters value during game runtime, the VR feels off, the movement of the level doesn’t match the movement of the VR boundaries when moving around.

Same issue here (only on Vive, not with the Rift). It works when setting the scale in the world settings but not when setting it via Blueprint, reproducable in a clean project.

VizualTek’s answer worked for me (closing all tabs in the editor). Thanks for following up on it.

This exactly, i closed all tabs besides the level tab and the hmd is no longer disrupted by setting world to scale in the level blueprint.

Thanks @VizualTek closing all (other) tabs did the trick!
This weirdness is still occurring in 4.21

Confirmed, closing extra tabs made a massive different. 4.21. World scale can break if other tabs are open.

Confirmed that this is still an issue in 4.22. Have submitted it as a bug to Epic

Confirm the issue. Set World to Meters Scale makes VR view twitch when additional tabs are open. If there are no tabs its fine.

Having to close tabs is still the fix 4.27.0

Is anyone having issues with ‘cross-eyed’ rendering of things like print strings and other debug lines when adjusting World to Meters Scale? For me, it’s rendering the left eye logs too far to the left, mostly off screen, the right eye stays centered. and is what I’m seeing mostly when in headset (quest2)