Download

Changing from Baked GI to Direct GI issue

Hey guys again, about the question in title
I’m changing from baked GI to dinamic GI

  • I’ve set the r.LightVol…] = 1 in the editor
  • I’ve set the indirect light property lightmass
  • In PostProcess I’ve activated the IndirectLight, set to BruteForce and all the rest

I cant see any changes in the project.
Just playing with indirect light parameters nothing changes… why?

Are you talking about ray tracing?

Global Illumination, I dont understand why it doesn’t affect my world

And yes Global Illumination requires raytracing calculation

does anyone know how please?

I have follow all the required, even mentioned in this official tutorial here: https://docs.unrealengine.com/en-US/Engine/Rendering/LightingAndShadows/LightPropagationVolumes/index.html
but that is basically how the dinamic GI looks like in my scene:

and this are all the settings from SunSky directlight to postprocess Volume. Please I’m asking your help f you notice something wrong in this settings or different by yours.
Cause I dont know what to do right now! It is so frustrating…

anyone please?

A few things are potential causes or sources of the problem(s).

  1. “Force no precomputed lighting” is enabled, while “Allow static lights” is enabled, which could create a conflict if using only dynamic (all movable) lighting. It’d be a bug, I think, though that’s arguable in terms of how the devs would probably see it.
  2. Indirect lighting bounces is low, given that it’s utilizing ray tracing global illumation and only 1 skylight bounce, though I’m not sure it would cause a surface to go completely dark.
  3. Under LPV Advanced settings, the Secondary Bounce Intensity and Geometry Volume Bias appear to be too low…yet I don’t know how the scene is supposed to look, so it might be wrong to suggest that both of those should be turned up. I had a problem with LPV before where it would over-brighten any surface it contacted and overlapped that was dark. It was due to something in the Advanced settings, but don’t recall what. If the LPV is overlapping the geometry in the screenshot, then it could be overriding the indirect intensity under Global Illumination somewhat. That’s what an LPV is for partly, to modify the existing lighting.
  4. Try Skylight Bounces at 3 or 4, Indirect Bounces at 5-7, and increasing the intensity of direct lighting. If that’s not working, then it’s certainly something else besides light intensity and bounces.

Hi Buddy… I’ve solved the problem into a separated project. To make the direct GI works we need to completely remove the LPV system from settings. No baked lights have to be in the scene… and it sounds pretty obvious

Now I only have a problem when I move the sunlight down (night ) because some of the scene appears to be still partially illuminated by GI
I need to automatically link the light parameters and other parameters to the light position, just opened another topic for that

cool, thanks for the info regarding night GI…
I thought it might be the LPV. That thing causes lots of problems, though it could useful.

I see that just changing some light parameters (like indirect light intensity for instance) the problem disappear, but how can I dinamically change this parameter based on Directlight daytime?